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1 Introduction
Maya Unlimited represents the total feature set of Maya software 
tools available from Alias. Maya Unlimited includes everything 
from Maya Complete plus additional tools.

Maya Unlimited includes Fluid Effects tools that allow for the 
simulation and rendering of viscous fluids, atmospheric, 
pyrotechnic, and ocean effects. Maya Cloth tools allow you to 
create simulations of fabric and clothing. Maya Fur lets you style 
and render short hair and fur effects using the Maya Artisan 
brush tools. Maya Live provides functionality to match original 
live-action footage with your 3D elements that were rendered in 
Maya.

The goal of this manual is to assist you in learning the features of 
Maya Unlimited.

If you have never used Maya Unlimited or Maya Complete, we 
recommend that you begin with Getting Started with Maya before 
attempting the lessons within Getting Started with Maya Unlimited.

This chapter provides the following information:

• About Getting Started with Maya Unlimited – Contents of the 
Getting Started with Maya Unlimited manual.

• Prerequisites – What you should know before using Getting 
Started with Maya Unlimited.

• Installing Maya Unlimited – Information on installing Maya 
Unlimited.

• Using the Getting Started with Maya Unlimited files – How to 
copy the files provided on CD-ROM for the Getting Started 
with Maya Unlimited lessons.

• Before you begin the lessons – Helpful instructions to aid your 
success with the lessons.
Getting Started with Maya Unlimited
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1 | Introduction 
  > About Getting Started with Maya Unlimited
About Getting Started with Maya Unlimited
Getting Started with Maya Unlimited introduces the modular areas 
of Maya Unlimited in a set of brief tutorials. The tutorials are 
designed to let you learn these modules at your own pace.

Getting Started with Maya Unlimited is not meant to replace the 
documentation that comes with the Maya software. Only the 
commands and options used in the lessons are explained in this 
manual. You will find the Maya Help provides an excellent 
companion reference to the lessons and much more.

Many of the tutorials in Getting Started with Maya Unlimited 
contain one or more separate lessons that provide step-by-step 
instructions for creating or accomplishing specific tasks within 
Maya. You can follow the tutorials in this book from start to finish 
or complete only the tutorials that correspond to your interests 
and needs.

Getting Started with Maya Unlimited is also available for use within 
the Maya Help. This version of Getting Started with Maya Unlimited 
contains mpeg movies for some of the lessons.

To use the tutorials from the Maya Help

1 In Maya, select Help > Tutorials.

The Maya Help window displays the Getting Started with 
Maya Unlimited tutorials.

2 Click the tutorial you want to work through.

The Maya Help displays the associated lessons for that 
tutorial.
Getting Started with Maya Unlimited
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1 | Introduction
 > Before you begin
Before you begin
We recommend that any new Maya user begin by completing the 
following:

• Viewing the Essential Skills Movies that are available when 
you first start Maya.

• Completing the Maya Basics tutorial (Chapter 2) in Getting 
Started with Maya which introduces many fundamental 
concepts and skills related to the Maya user interface.

• Completing the tutorials within Getting Started with Maya 
before attempting the lessons within Getting Started with Maya 
Unlimited.

Beyond that, you can attempt the tutorials in any order you want.

If you require an overview or review of basic mouse, 
keyboarding, and related usage techniques, we recommend that 
you refer to the documentation that came with your particular 
computer and operating system.

If you are new to 3D computer graphics and animation, you may 
want to obtain The Art of Maya (ISBN: 1-8948931-3-1) available 
from the Alias online store. It explains many concepts and 
techniques that are unique to the world of 3D computer graphics 
as they relate to Maya.

Installing Maya Unlimited
You must have Maya Unlimited installed and licensed on your 
computer system to successfully complete the lessons in this 
manual. To operate Maya Unlimited on your computer you must 
be running a qualified Windows, IRIX, or Linux operating system 
with the recommended minimum memory and storage 
requirements. Maya requires a three button mouse to access its 
full functionality for menus, commands, and 3D viewing.
Getting Started with Maya Unlimited

11



1 | Introduction 
  > Conventions used in this book
For complete instructions on qualified hardware and operating 
systems, as well as installation and licensing of the Maya 
software, please refer to the Installation and Licensing manual that 
came with your Maya software or see the Support section of our 
Web site at www.alias.com.

Conventions used in this book
Some important conventions used throughout Getting Started 
with Maya Unlimited are explained here.

Maya Unlimited is available for use on a wide range of operating 
systems. Any differences between operating systems when 
operating Maya are identified in the following ways:

(Windows), (IRIX), & (Linux)

The screen illustrations and examples within Getting Started with 
Maya Unlimited vary among the Windows, IRIX, and Linux 
operating systems. Maya’s interface is generally consistent across 
these systems.

When instructed to select a menu within Maya, we use the 
following convention:

• Menu > Command (for example, File > New Scene)

When you are instructed to select the option box for a particular 
menu item within Maya, we use the following convention:

• Menu > Command > Option (for example, Create > NURBS > 
Primitives > Sphere > 
Getting Started with Maya Unlimited
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1 | Introduction
 > Using the lesson files
Using the lesson files
Some of the Getting Started with Maya Unlimited lessons have 
accompanying Maya files that were created for use with the 
lessons. These files are contained on the Maya Documentation, 
Lessons, and Extras CD-ROM which is included with your Maya 
Unlimited software package. To use the lesson files, do one of the 
following:

• Open the Getting Started with Maya Unlimited lesson files 
directly from the Maya Documentation, Lessons, and Extras CD-
ROM.

• Copy the Getting Started with Maya Unlimited lesson files to 
your computer’s hard drive and then open them from your 
hard drive.

To open the lesson files from your CD-ROM drive

1 Insert the Maya Documentation, Lessons, and Extras CD-ROM 
into your drive.

2 Within Maya, select File > Open Scene.

3 Navigate to the CD-ROM drive, locate the Getting Started 
with Maya Unlimited lessons folder, and select it.

4 Double-click on the Getting Started with Maya Unlimited 
lessons folder to view its contents.

5 Double-click the specific lesson and tutorial file to open it in 
Maya Unlimited.
Getting Started with Maya Unlimited
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1 | Introduction 
  > Restoring default user settings
To copy the lesson files from the Maya 
Documentation, Lessons, and Extras CD-ROM

1 Insert the Maya Documentation, Lessons, and Extras CD-ROM 
into your drive.

2 From the CD-ROM, copy the Getting Started with Maya 
Unlimited lessons folder to your computer into the following 
directory:

(Windows) drive:\Documents and Settings\username\
My Documents\maya\projects

(IRIX & Linux) ~username/maya/projects

When you are asked to open specific lesson files, open the 
Getting Started with Maya Unlimited lessons that you have 
copied to the projects directory.

Restoring default user settings
If you have already used Maya or have a prior version of Maya 
installed, you should restore the default settings for Maya before 
you begin the lessons. This ensures that Maya appears and 
operates exactly as the lessons describe.

If you are an existing user of Maya, we recommend that you save 
your existing preferences for later use prior to restoring the 
default user settings.

To save your existing custom user preferences

1 Ensure Maya is not running.

Each time you exit Maya, it saves the configuration of most 
components of your user interface so it appears the same 
when you start it the next time. It writes the preferences to a 
directory called prefs. If you rename the prefs directory, your 
original preferences will be maintained and Maya will create a 
new prefs directory the next time it is run.
Getting Started with Maya Unlimited
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 > Restoring default user settings
2 Rename your existing user preferences file to a name, for 
example, myprefs. The prefs directory path is:

(Windows) drive:\Documents and Settings\username\
My Documents\maya\6.5\prefs

(Mac OS X) Users/username/Library/Preferences/Alias/
maya/6.5/prefs

(IRIX & Linux) ~username/maya/6.5/prefs

If you have a previous version of Maya installed, also rename 
that prefs directory to a new name such as myprefs. Maya will 
load older preferences if they exist from a previous version.

3 Start Maya and begin the Getting Started with Maya lessons.

To restore your custom user preferences after doing 
the lessons

1 Ensure Maya is not running.

2 Rename the previously changed preferences back to prefs.
Getting Started with Maya Unlimited
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2 Hair
With Maya Hair, you can create a dynamic hair system to model 
realistic hairstyles and hair behavior. 

Since Hair is a generic dynamic curve simulation, you can also use 
these curves to create non-hair effects, including ropes, chains, a 
suspension bridge, sea creatures, or lofted surface from a curve.

With Hair you can simulate:

• natural movement and collisions of long hair

• hair blowing in the wind or being blow dried

• hair when swimming underwater
Getting Started with Maya Unlimited
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2 | Hair 
  > 
• various hairstyles, including ponytails, braids, and updos

• other dynamic curve effects such as ropes, chains, cables, 
wires, etc.

A hair system is a collection of hair follicles. 

A hair follicle in human hair typically hosts one hair, whereas in 
Maya each hair follicle hosts a hair curve. The hair follicle controls 
the attributes and curves associated with a particular hair clump, 
and how the hairs attach to a NURBS or polygonal surface. The 
input to each follicle is a Start Position NURBS curve, a surface 
and a UV position to attach to. 

When creating hair, the hair system output can be in the form of 
NURBS curves, Paint Effects strokes, or both. If the specified 
output when creating hair is NURBS Curves, each follicle will 
contain one NURBS curve that represents the position of the hair 
in that follicle. If the specified output is Paint Effects, each follicle 
has a hair clump, made up of Paint Effects strokes. 

There are various attributes on a hair system for modifying the 
look and behavior of the hair as a whole. There are also follicle 
level attributes that will override the hair system attributes; the 
visible result will be affected by both the follicle and hair system 
attributes.

You can have more than one hair system on the same surface.

With the Paint Hair Tool you can create new hair systems, add 
and remove follicles, as well as paint hair attributes, including 
Clump Width Scale, Stiffness, and Braid.

Paint Effects hair can be rendered using the Maya Software 
renderer. You can also convert Paint Effects hair to polygons and 
render in another renderer, such as mental ray. Or you can output 
just the dynamic NURBS curves to an external renderer, such as 
Renderman.
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Consider outputting to Paint Effects if you want to:

• render with the Maya Software renderer

• convert the Paint Effects hair to polygons and render in any 
renderer

Consider outputting to NURBS curves if you want to:

• use the curves as path or control curves for any standard 
Paint Effects brush, such as feathers or vines. These brushes 
behave differently than the default built in Paint Effects as the 
curves are not the hairs, but controls that interpolate and 
affect Paint Effects. This scenario is slower to update and 
takes a bit of time to set up.

• select a few Current Position curves and loft a surface through 
them with construction history.

• extrude a circle down the curve to create a tube.

• use the curves for output to another renderer that directly 
supports curve rendering. 

Consider outputting to both NURBS curves and Paint Effects if 
you want to:

• use both the curves (for example, as particle emitters to 
simulate spray flying off wet hair) and render using the 
integrated Paint Effects either directly or by converting to 
polygons.
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About hair simulation
This is the general workflow to create and animate hair:

• create hair on models

• style hair curves

• modify hair attributes

• set up hair shading/shadowing

• render the scene 

This chapter includes these lessons:

• ”Creating a basic hairstyle” on page 22

• ”Creating a dynamic non-hair simulation” on page 48

Preparing for the lessons
To ensure the lesson works as described, do these steps before 
beginning:

1 Make sure you understand the basic concepts of modeling 
NURBS curves, animation, and dynamics. For more 
information, see Maya Help.

2 Select the Dynamics menu set.

Unless otherwise noted, the procedures in these lessons 
assume the Dynamics menu set is selected. 

3 Select File > New Scene to create a new scene before you start 
each lesson. For those scenes that require you to open a file, 
the Hair scene files are located in UnlimitedLessonData/
Hair/scenes on the Maya Documentation, Lessons, and Extras 
CD or on the drive where you copied the Getting Started with 
Maya data files.

4 Select Window > Settings/Preferences > Preferences. Click 
Timeline under Categories and make sure the Playback Speed 
is set to Play every frame. Dynamic animation plays more 
accurately with this setting. 
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Also set the playback and animation end times to 10000. This 
ensures you have lots of time to interact with the playback of 
the hair simulation.

5 We provide a completed scene for each of the lessons in this 
chapter. If you want to see the expected results of the lessons, 
you can open the scenes from UnlimitedLessonData/Hair/
scenes on the Maya Documentation, Lessons, and Extras CD or 
from the drive where you copied the Getting Started with 
Maya data files. The scene filenames end with Final.mb, for 
instance, hairFinal.mb.
Getting Started with Maya Unlimited

21



2 | Hair 
Lesson 1  > Creating a basic hairstyle
Lesson 1 Creating a basic hairstyle
You can create hair on NURBS and polygonal surfaces. For 
polygons, UVs should be non-overlapping and fit between 
0 and 1. Automatic mapping is a quick way to achieve this. (See 
Map UVs onto polygons automatically in the Polygonal Modeling 
guide in Maya Help.) In this lesson you are creating hair on a 
head model.

There are three sets of curves for the hair system. 

Start Curves/
Position

This is the position of the hair at the start 
frame of the simulation. When first created, 
the Start curves stick straight out from the 
surface.

Rest Curves/
Position

This is the position of the hair when no 
forces (such as gravity) are acting upon it. 
You can use these curves to influence the 
shape of the hair.

Working with Rest curves is like styling hair 
with hairspray. The Rest curves are styled 
into curls and flips, etc. When the simulation 
is played back, the hair adheres to the Rest 
curves position as much as possible 
depending on dynamic forces and attribute 
settings in the hair system and follicles. For 
example, if your hair is not very stiff and 
you’re simulating a windy day, the 
hairspray (Rest curves position) is less likely 
to hold the hair in position.
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In this lesson you are introduced to some of the basic concepts of 
hair by creating a simple long hairstyle. In this lesson, you learn 
how to:

• Create hair on a surface.

• Play a hair simulation and interact with it during playback.

• Manipulate hair curves to create a hairstyle.

• Use collision constraints to make hair collide with a model’s 
head, neck and shoulders.

• Modify hair attributes.

• Set up hair self shadows.

• Render hair.

Lesson setup
In this lesson, you'll work with a scene we created for your use.

1 Before beginning the lesson, do the steps in ”Preparing for the 
lessons” on page 20.

2 Open the scene named hairStart.mb from the Maya 
Documentation, Lessons, and Extras CD or from the drive where 
you copied the Getting Started with Maya Unlimited data 
files. The file is located in UnlimitedLesssonData/Hair/
scenes. 

Current Position This is how the hair behaves when you play 
the simulation, which includes dynamics. 
Do not edit the Current Position; just view it. 

The Stiffness and Iterations attributes in the 
Hair system’s Dynamics section are what 
control the tolerance of the Current Position 
achieving the Rest Position.
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This scene provides a NURBS head model, named Marion, 
and the scalp surface for creating the hair. Part of the model 
has been templated to make picking the scalp easier.

Creating hair on a surface
When you first create hair it appears sticking out normal to the 
surface. For a more natural look, play the hair simulation to see 
the hair react to gravity and then you can set a more realistic Start 
position for the hair. In these steps you create hair on a NURBS 
model and set a Start position after playing the simulation. You 
use Interactive Playback to play the simulation while adjusting 
dynamic hair system attributes and see how your changes affect 
the simulation.

To create hair on a model

1 Select Marion’s scalp, as shown in the image below.

Marion’s scalp 
is selected
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2 Select Hair > Create Hair >  and in the Create Hair Options 
window, specify the following:

• Set Output to Paint Effects.

• Set the U Count to 26 and the V Count to 22. These 
determine how many hair curves within each UV range.

• Set the Points Per Hair to 10. This sets the number of 
segments per hair. More segments are needed to make 
long hair look natural or to create complex short 
hairstyles. As you increase the number of segments, you 
decrease the performance (speed) of the simulation.

• Set the Passive Fill to 0. No passive curves will be used in 
this tutorial. The behavior of passive curves is 
interpolated between neighboring active curves. For more 
information, see Passive Curves in the online Hair and 
Dynamic Curves guide.

• Set the Length to 10. This value is relative to the world 
space units. 

• Set the Randomization to 0.5. A value of 1 represents total 
randomization of placement of hair curves on the surface, 
whereas a value of 0 represents no randomization. 

• Both the Create Rest Curves and Edge Bounded options 
should be turned off.

• Turn the Equalize option on. This ensures the hair curves 
are evenly distributed over the surface.

• Click Create Hairs.

The hair is attached to the scalp and sticks out perpendicular 
to the surface. You are looking at the Current Position of the 
hair, which is also referred to as the “dynamic” position. Do 
not edit the hair curves in this view; edit only in Start Position 
or Rest Position.
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To play the hair simulation

1 Click the Play  button to play the simulation. 

The hair falls due to default dynamic forces, such as gravity, 
which are found in the hair system attributes. However the 
hair takes a while to fall, which is as a result of a high Display 
Quality setting.

2 Click the Stop  button to stop the simulation when the 
hair is relaxed as it is in the following image.

Note Make sure the End Time and Playback End Time in the 
Range Slider are both set to 10000.

When Marion’s hair 
is first created it is 
perpendicular 
(normal) to the scalp.

The red circles are 
the follicles.
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Notice the hairs are quite stiff and stick out from the scalp 
instead of naturally falling closer to the scalp. To make the 
hair appear less stiff you can either increase the number of 
Points Per Hair (segments), which increases the simulation 
and render time, or you can reduce the Stiffness value in the 
hair system’s Dynamic attributes. 

In the next part of the lesson you adjust dynamic settings of 
the hair system, including Stiffness and Gravity, to achieve 
more naturally behaving hair. 

To improve playback performance and modify dynamic 
settings

1 In the Attribute Editor (Ctrl + a) select the hairSystemShape 
tab and change Display Quality to 2. This affects how many 
hairs display in the scene view, but has no effect on how 
much hair appears in the software render. By reducing the 
Display Quality, this speeds up the playback of the hair 
simulation.

After playing the 
simulation for a 
while Marion’s 
hair begins to 
relax, but it is 
still quite stiff 
and doesn’t rest 
near the scalp 
as hair does 
naturally.
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2 In the Dynamics section the default value for Stiffness is 0.15. 
Since the hair is quite stiff, reduce the Stiffness value to 0.07.

3 Select Solvers > Interactive Playback to play the simulation. 
Watch the hair begin to relax more.

4 With the simulation still playing go to the Dynamics section of 
the hairSystemShape tab and change the Gravity value to 2.5. 
Watch the hair relax even more and rest closer to the scalp, as 
hair does naturally. 

5 Click the Stop  button when the hair has relaxed as in the 
following image.

To set the position of the hair for the start frame

1 When you are playing the hair simulation, by default you are 
viewing the Current position curves. To select all the Current 
position curves, click any hair curve and then select Hair > 
Convert Selection > to Current Positions.

2 To set the start frame of the hair simulation to how the hair 
appears now, select Hair > Set Start Position > From Current.
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3 Select Hair > Display > Start Position to view the Start curves 
and see that they took on the Current Position. 

4 Click the  button to rewind to the start frame.

The position of the hair at the start frame is now relaxed.

Styling the hair
To style the hair you manipulate either the Start or Rest curves to 
achieve the look you want. In these next steps you first edit the 
Start curves to create the basic hair shape. Then you set an initial 
Rest position for the hair and style the hair by editing the Rest 
curves. 

To edit the Start curves to create the basic hair shape

1 Display the Start curves. (Hair > Display > Start Position)

2 Tumble the camera so you’re looking at the side of Marion’s 
head.

3 To pick the Start curves on the front half of Marion’s face, do 
the following:

• Click the Object Selection Mask  button on the Status 
Line and select All Objects Off.

• Click the  button on the Status Line to restrict the 
selection to curves.

• Drag around the front of Marion’s head. Only those Start 
curves are selected, as shown in the following image.
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4 Now tumble the camera so Marion is again facing you.

5 To trim the Start curves in the front, do the following:

• Select Hair > Modify Curves > Lock Length. This allows 
you to manipulate the curve while maintaining the 
curve’s hull length.

• Click the  in the Status Line to display the curves’ 
CVs.

• Using the Lasso Tool , select CVs in an inverted U-
shape around the front of Marion’s face, as shown in the 
following image.

• Press Delete to remove the selected CVs.
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6 To curl under the ends of all the Start curves, do the 
following:

• Click the  button to display the curves and then drag 
around Marion’s head to select all the Start curves. 

• Click the  button to display CVs and then, using the 
Select Tool, select the CVs in the bottom half of all the 
curves.

• Select Hair > Modify Curves > Bend > ❒.

• In the Bend Curves Options window, set Bend Amount to 
0.5 and Twist to 1.0 and then click Bend Curves.

Selected CVs deleted 
to trim hair

Start curve CVs selected in 
an inverted U-shape
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The selected CVs are bent under towards Marion’s neck. To 
fix any unruly hairs, you could select them and then select 
Hair > Modify Curves > Smooth.

7 Click the  button to display the curves.

8 Change the display to include the Start curves and the 
Current Position. (Hair > Display > Current and Start)

9 Click the Play  button to play the hair simulation. 

Even though you styled the Start curves, notice how they fall 
straight and lose the bend at the end. Start curves only define 
the position of the hair at the Start frame of the simulation; 
once the simulation is started the Start curves are affected by 
the dynamic forces applied to the hair system. To “hairspray” 
a hairstyle, you need to style Rest curves and adjust dynamic 
hair system settings. In the next steps you create Rest curves 
from the Start curves.

10 Click the Stop  button to stop the simulation.

Selected CVs 
are curled 
under using 
Bend
Getting Started with Maya Unlimited

32



2 | Hair
Lesson 1 > Styling the hair
To create and modify the Rest curves to achieve a 
hairstyle

1 To create Rest curves from the shaped Start curves, do the 
following:

• Select Hair > Display > Start Position.

• Using the Select Tool , drag to select all the Start 
curves and then select Hair > Set Rest Position> From 
Start.

2 To see the new Rest curves, select Hair > Display > Current 
and Rest.

3 Select all the hair curves and then click the Play  button to 
play the simulation. Watch how the Current position hairs 
flop down because the Gravity value is quite high (2.5). 

4 To see what the hair would look like without any gravity, go 
to the Dynamics section in the hairSystemShape tab and 
change the Gravity value to 0.

Watch the hair try to achieve the Rest position.

5 After the hair reaches the Rest position, change the Gravity 
value back to 1.0.

6 As the hair starts to fall due to gravity, increase the Stiffness 
value to 0.2.

If some Rest curves won’t relax and stabilize, increase Length 
Flex and Iterations in the hairSystemShape tab.

7 Once the hair stabilizes, click the Stop  button to stop the 
simulation.

8 You can further “hairspray” the curled ends of the Rest curves 
using the Stiffness Scale attribute. The curve in the Stiffness 
Scale graph illustrates the amount of stiffness applied along 
the hair curve from root (left side of the graph) to tip (right 
side of the graph). Go to the Dynamics section in the 
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hairSystemShape tab and change the Stiffness Scale attribute 
as shown in the following image. These changes add more 
stiffness to the end of the hair, which will hold the bend more 
firmly.

9 Play the simulation to see the effect of the changes to Stiffness 
Scale.

10 Stop the simulation once the hair relaxes as in the following 
image.

11 To reset the Start curves from the simulation, select Hair > Set 
Start Position > From Current.

12 Click the  button to rewind to the beginning of the 
simulation.

Default Stiffness Scale Modified Stiffness Scale:

- click the middle of the graph to add a new 
entry and set its Selected Value to 0.4

- click the entry on the right side of the graph  
and change its Selected value to 0.6
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Setting up hair collisions
Before trimming Marion’s hair you may have noticed that some 
hairs intersected her face. As well hairs currently intersect the 
lower part of her neck. To fix this you set up hair collisions. You 
can set hair to collide with itself, other objects or the ground 
(grid). In the next steps you use collision constraints to prevent 
the hair from intersecting with Marion’s head and neck. 

All the hair 
curves are 
selected. 

The green 
curves 
represent the 
Current 
Position.

The white 
curves 
represent the 
Rest Position.

Notice the 
hairs at the 
bottom are 
intersecting 
with the upper 
part of 
Marion’s torso
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To make Marion’s hair collide with her head and neck

1 In the panel, select Show > Locators so you can see collision 
constraints, which are locators, when you create them.

2 To create the collision constraint for Marion’s head, do the 
following:

• Select Hair > Display > Start Position.

• Using the Select Tool, drag around all the hair curves and 
select Hair > Convert Selection > to Start Curves.

• Select Hair > Create Constraint > Collide Sphere.

• Using the Scale Tool, resize the sphere so it expands 
beyond Marion’s head and you can see it.

• Using the Move Tool, move the sphere up the Y-axis so 
the top of the sphere is aligned with the top of Marion’s 
head.

• Using the Scale Tool again, resize the sphere so it matches 
the basic shape of Marion’s head. First try scaling in the X 
direction to adjust the width of the sphere from ear to ear. 
Then tumble the camera to see the side of Marion’s head 
and scale in the Z direction to adjust the sphere width 
from the back of Marion’s head to her nose. You may also 
need to move the sphere to tweak its size and position, as 
shown in the images below.
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3 To create the collision constraint for Marion’s upper torso, do 
the following:

• Using the Select Tool, drag around the hair curves and 
select Hair > Convert Selection > to Start Curves.

• Select Hair > Create Constraint > Collide Sphere.

• Using the Scale Tool, resize the sphere so it extends 
beyond Marion’s neck and you can see it.

• Using the Move Tool, move the sphere down the Y-axis 
so the top of the sphere is aligned with the top of 
Marion’s torso.

• Using the Scale Tool again, resize the sphere so it matches 
the basic dimensions of Marion’s upper torso. First try 
scaling in the X direction to adjust the width of the sphere 
from shoulder to shoulder. Then tumble the camera to see 

See the sphere width from ear to 
ear and height from the top of 
Marion’s head to below her chin

See the sphere width from the 
back of Marion’s head to her nose
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the side of Marion’s head and scale in the Z direction to 
adjust the sphere width from the back of Marion’s torso to 
the front of it. You may also need to move the sphere to 
tweak its size and position, as shown in the images below

4 Select Hair > Display > Current Position.

5 Click the  button to rewind to the start frame and play the 
simulation.

Watch how the hair collides with the collision constraints you 
created. The hair at the front now rests on the torso and the 
hair at the back curls under the torso, instead of intersecting it 
like it did before the collisions were set.

6 Stop the simulation when the hair is relaxed. Should the hair 
be unruly and not relax, you may need to increase the 
Stiffness or the Iterations in the Dynamics section of the 
hairSystemShape tab of the Attribute Editor.

See the sphere width from shoulder 
to shoulder and height from the top 
of Marion’s torso to the bottom of it

See the sphere width from the 
back of Marion’s torso to the front 
of it
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7 Select Hair > Set Start Position > From Current so the hair 
respects the collisions at the start frame of the simulation.

8 Select Show > Locators to turn them off, which hides the 
collision constraints.

Rendering the hair
When you modify hair attributes, many of these changes are not 
visible in the scene view; the Paint Effects hair must be rendered 
in the Maya Software renderer. In the next steps you render 
Marion’s hair as it is now, which allows you to see what aspects of 
the hair need work to make it look more realistic. Before 
rendering, be sure to set the appropriate Render Global settings.

To render Paint Effects hair using the Maya Software 
renderer

1 Modify the Render Globals settings for Paint Effects.

• Click the Render Globals  button on the Status Line. 
The Render Global Settings window appears.

• Select Maya Software from the Render Using drop-down 
list.

Once the hair 
relaxes in the 
simulation, 
see how it 
rests against 
the collision 
constraints
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• In the Maya Software tab, go to the Paint Effects 
Rendering Options section and turn on Oversample and 
Oversample Post Filter. These help achieve a better look 
for the Paint Effects rendering. The option Enable Stroke 
Rendering is already on by default.

• Click Close to close the Render Global Settings window.

2 Before rendering be sure to display the hair system’s Current 
Position. (Hair > Display > Current Position)

3 Click the Render Current Frame  button on the Status 

Line. 

The hair model is rendered and should look something like 
the image below.

Modifying hair attributes
You can modify the hair as a whole by modifying the hair system 
attributes. You can modify the look of individual hairs or clumps 
of hair by editing their follicle attributes. In the next steps, you 
modify various hair system attributes to make Marion’s hair look 
fuller and more realistic. Then you add curl to Marion’s hair.

This is how the 
hair looks in 
the Maya 
Software 
render before 
modifying hair 
attributes. The 
hair is sparse 
at the crown, 
which can be 
fixed by 
increasing the 
Clump Width 
value.
Getting Started with Maya Unlimited

40



2 | Hair
Lesson 1 > Modifying hair attributes
To modify the thickness of the hair all over

1 To select the hair system, drag around the hair curves and 
select Hair > Convert Selection > to Hair Systems.

2 Go to the Clump and Hair Shape section in the 
hairSystemShape tab of the Attribute Editor and adjust the 
following:

• Hairs Per Clump to 30, which controls the number of 
hairs per curve (hair clump). Increasing the number of 
Hairs Per Clump increases the rendering time.

• Sub Segments to 2, which adds this many points between 
Segments/points and helps to smooth the hair curves.

• Thinning to 0.5, which controls how much the hair thins 
out from root to tip.

• Clump Width to 0.3, which controls the width of the hair 
clump from root to tip. To further modify the hair clump 
width, you could adjust the Clump Width Scale attribute, 
which allows you to vary the width along the hair from 
root to tip.

• Hair Width to 0.02, which controls the width of each hair.

3 Click the Render Current Frame  button to render the hair 

to see the changes you’ve made to the hair.
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To make hair curly

1 With the hair system still selected, go to the Displacements 
section in the hairSystemShape tab of the Attribute Editor and 
set the following:

• Curl to 1, which is the amount of curl displacement 
applied to each hair. The amount of displacement is 
relative to the hair width.

• Curl Frequency to 15, which is the rate of curl. The higher 
the value is, the more curls there are.

2 Click the Render Current Frame  button to render the hair 

to see the changes you’ve made to the hair.

After modifying 
hair and clump 
attributes the 
hair looks 
more full and 
realistic
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Setting up shadowing on hair
Hair, by default, is translucent so you need to set up self 
shadowing, otherwise hair appears glowy, like nylon. The darker 
the hair color is, the more important the specular color and 
highlights become. 

There are three directional lights in this scene. In the software 
render you did in the previous steps, Marion’s hair appears blond 
and glowy, even though the default hair color is dark brown, as in 
the scene view. This apparent hair color discrepancy occurs 
because:

• hair is by default translucent (like a glass tube)

• the hair is being lit by all three lights, therefore the intensity of 
the light is tripled

• there are no shadows, so all the hairs are illuminated

In these next steps you set up shadows on all three lights.

To set up shadows and self shadows on hair

1 Select Window > Outliner.

2 In the Outliner menu, select Show > Objects > Lights. 

The rendered 
hair after curl 
attributes have 
been applied
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3 Select one of the three directional lights.

4 In the light’s Attribute Editor, go to the Shadows section and 
in the Depth Map Shadow Attributes subsection, turn on Use 
Depth Map Shadows.

Normally you would increase the Dmap Filter Size to blur the 
light in the hair for realism, and increase the Dmap Bias, 
which sets how far the light filters through the hair. These 
attributes were set for you in the scene.

5 Repeat steps 3 and 4 for the other two directional lights.

6 Render the hair to see the changes.

The shadows on the hair are hard and there is very little 
specularity. You fix this in the next steps.

To create specular highlights on hair

1 To select the hair system, drag around the hair curves and 
select Hair > Convert Selection > to Hair Systems.

2 Go to the Shading section in the hairSystemShape tab of the 
Attribute Editor and set the following:

• Click the Specular color box and set the values as show in 
the image below.

• Increase Specular Power to 15.

3 Render the hair to see the changes. The hair looks much more 
natural now.
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Beyond the lesson
In this lesson you learned how to:

• Create dynamic hair on a surface.

You can add hair to a NURBS or polygonal surface by 
creating or painting the hair. For polygons, UVs should be 
non-overlapping and fit between 0 and 1. Automatic mapping 
is a quick way to achieve this (see Map UVs onto polygons 
automatically). For more information, see Creating hair in the 
online Hair and Dynamic Curves guide.

Before creating hair, you should determine which renderer 
you’ll be using as this will affect what type of hair output you 
select: NURBS curves or Paint Effects, or both.

• Interact with the dynamic playback.

Using interactive playback you can modify the hair and see 
the hair react to dynamic forces. For more information, see 
Playing a Hair simulation in theonline Hair and Dynamic 
Curves guide.

Your final 
render with the 
changes to the 
specular color 
and power 
should look 
something like 
this. Marion’s 
hair is brown, 
but with a 
warm, golden 
specular 
highlight.
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• Model hair curves.

Style hair by transforming hair curves and using Lock Length 
to maintain the length between CVs on a curve. You can also 
use Fields to style hair and then add constraints to hold hair 
in position. For more information, see Styling the hair in 
theonline Hair and Dynamic Curves guide.

• Modify hair system and follicle attributes.

You can change the look (color, curl, etc.) of the overall hair 
by modifying attributes in the hairSystemShape node. But 
individual follicle attributes can be modified in the 
follicleShape node, which override or blend with the hair 
system attributes. For more information, see the following 
topics in the online help: Hair system attributes 
(hairSystemShape node), Follicle attributes (follicleShape node) 
and Setting up hair shading.

• Render the hair.

Paint Effects hair can be rendered using the Maya Software 
renderer. You can also convert Paint Effects hair to polygons 
and render in another renderer, such as mental ray. Or you 
can output just the dynamic curves to an external renderer, 
such as Renderman. For more information, see Rendering 
Scenes with Hair in the online Hair and Dynamic Curves 
guide.

You can also create non-hair models and effects with Hair. Any 
NURBS curve can be made into a dynamic hair curve. In addition 
to creating long hair and hairstyles you can use hair curves to 
create:

• ropes and chains (dynamic curves)

• a fish (wire deformer)

• a fishing line (single hair with expressions)

• an octopus (select hair curves and create a lofted surface)
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• a paint brush painting on canvas, bristles colliding with the 
surface (hair simulates paint brush bristles, Fluid emitters on 
the canvas controlled by expressions)

In addition you can assign a Paint Effects brush to a hair system 
as shown in the image below.

Image created by Duncan Brinsmead
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Lesson 2 Creating a dynamic non-hair 
simulation
Using Maya Hair, you can create dynamic non-hair models and 
effects. You can make NURBS curves dynamic, or you can use a 
hair system to create a non-hair simulation, such as chains or 
ropes. In this lesson, you create a hair system to simulate a beaded 
curtain. To make the hairs look like beads, you assign a Paint 
Effects brush to the hair. Then you modify the hair attributes and 
set constraints so the hair behaves like a beaded curtain hanging 
from a curtain rod.

In this lesson, you learn how to:

• Make hair collide with an object

• Assign a Paint Effects brush to hair

• Set up hair constraints
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Lesson setup

In this lesson, you'll work with a new empty scene and change the 
playback range.

1 Select File > New Scene.

2 In the Time Slider change both the End Time value and 
Playback End Time value to 300.

Setting up the curtain scene
In these steps you model a 2D curtain rod from a plane and attach 
hair to it. Then you add and keyframe a sphere in the scene to 
later be used as a collision object.

To create the curtain using Hair

1 To create a NURBS plane, select Create > NURBS Primitives > 
Plane.

2 Using the Scale Tool , resize the plane in the X direction 
as shown in the image below.
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3 With the plane selected, select Hair > Create Hair > ❒, set the 
following options:

• Output to NURBS Curves

• U Count to 20, V count to 1

• Points per Hair to 12

• Passive Fill to 0

• Length to 10

• Randomization to 0

• Turn off the options Create Rest Curves, Edge Bounded 
and Equalize

• and click Create Hair. Hair is created and attached to the 
plane.
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4 Select the plane and, using the Rotate Tool , rotate the 
plane so the hair appears to be on the underside of the plane. 

Then, using the Move Tool , move the plane up the Y axis 
so the bottom of the hair just touches the ground plane, as 
shown in the following image.

5 Create a directional light (Create > Lights > Directional Light) 
and do the following:
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• Move the light above and to the left of the curtain.

• Rotate the light so it aims at the curtain.

• In the light’s Attribute Editor (ctrl + a) go to the 
Directional Light Attributes section and change the 
Intensity value to 1.5.

6 Create a NURBS sphere (Create > NURBS Primitives > 
Sphere) and move it along the Z-axis so it’s in front of the 
curtain.

7 To set the start keyframe for the sphere, do the following:

• Go to frame 1 on the Time Slider.

• In the Channel Box, drag to select the Translate X, Y, 
and Z channels.

• Right-click the channels and select Key Selected.

8 Set the keyframe for the sphere having moved towards the 
curtain and passed through it, as in the image below.

• Go to frame 100 in the Time Slider.

• Move the sphere in the Z direction as shown in the image 
below.

• In the Channel Box, select the Translate Z channel.
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• Right-click the channel and select Key Selected.

9 Rewind the Time Slider to 0 and play the animation.

The sphere passes through the curtain as though the curtain 
weren’t there. In the next steps you set the sphere as a 
collision object with the hair.

Making the hair collide with another object
To have hair interact with a surface, you must set the hair to 
collide with the surface. A collision object can be a NURBS or 
polygonal surface. In the next part of the lesson you set the 
curtain to collide with the sphere and then play the simulation.

To enhance the curtain for collisions

1 To select the hair system, drag around the hair curves and 
then select Hair > Convert Selection > to Hair Systems.

2 In the hairSystemShape tab of the Attribute Editor, set the hair 
system attributes as follows:

• In the Clump and Hair Shape section, set Clump Width 
to 0. 

• In the Dynamics section, set Stiffness to 0.

Time Slider = 100
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To make the hair collide with the sphere

1 Select the hair system and the sphere (drag around the hair 
curves and sphere).

2 Select Hair > Make Collide.

3 Play the simulation.

Now the sphere collides with the curtain, pushing the strands 
of hair aside as it passes through.

Assigning a Paint Effects brush to the hair
You can assign a Paint Effects brush to a hair system to achieve a 
variety of effects. In these next steps you apply the red beads 
brush to the hair system to create the beaded curtain. Then you 
modify the brush and hair system settings to achieve the desired 
look.

To turn the hair curtain into a beaded curtain

1 To select the hair system, drag around the hair curves and 
select Hair > Convert Selection > to Hair Systems.

2 Open the Visor. (Window > General Editors > Visor)

3 Go to the glass folder and select the beadsRed.mel brush.

4 Select Hair > Assign Paint Effects Brush to Hair.

You don’t see the beads in the scene view, but you will when 
you render it later using the Maya Software renderer. The 
brush needs some adjustments to make it look like a beaded 
curtain when it is rendered.

5 In the hairSystemShape tab of the Attribute Editor, set the 
following:

• Hairs Per Clump to 1 so there is one strand of beads

• Hair Width to 0.03 

• in the Shading section, Hair Color to white so the brush’s 
bead color appears
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• in the Shading section, Hair Color Scale to white so the 
brush’s bead color appears

• in the Shading section, Specular Color to red

• in the Displacements section, Noise to 0.5 to create some 
variety in the appearance and behavior of the beads

6 In the beadsRed tab of the Attribute Editor, go to the 
Texturing section and change the U Repeat to 10 so the beads 
appear as a more realistic bead size. (If the beadsRed tab does 
not appear in the Attribute Editor, re-select the hair curves. 
The beadsRed tab should now appear.)

7 Dolly in close to the curtain (Alt + the left mouse button + the 

right mouse button) and click the  button to render the 

current frame.

Setting up constraints
In these next steps you tie up the middle section of the beaded 
curtain by first modeling the Start curves into a bound position 
and then creating a constraint to hold the curves in that position 

The rendered beaded curtain should look 
something like this.
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during playback. With a Hair to Hair constraint the hair curves 
stick together at the constraint locator, but also dynamically move 
from root to tip when forces or collisions occur. 

To model the curtain into a tied-back position

1 Dolly and tumble in the scene until you are facing the curtain 
directly.

2 Drag to select all the hair curves and then select Hair > 
Convert Selection > to Start Curves.

3 Select a block of Start curves in the middle of the curtain.

4 Select Hair > Modify Curves > Lock Length. This ensures the 
entire curve is modified when you transform CVs in the next 
steps.

5 Click the  button on the Status Line to display the CVs on 
the curves.
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6 Select the middle three rows of CVs on the selected hair 
curves and then, using the Scale Tool, scale the CVs inwards 
so the hairs are pulled together. 

To constrain the curtain in the tied-back position

1 Click the  button on the Status Line to display the Start 
curves (not the CVs).

2 With the bound hair curves still selected, select Hair > Create 
Constraint > Hair to Hair. 

The middle rows of CVs are selected The middle rows of CVs are scaled inwards 
so the hair curves appear bound
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A constraint locator is created and connected to the selected 
curves.

3 In the hairConstraintShape tab in the Attribute Editor, set the 
constraint attributes as follows:

• Stiffness to 0.5 (default)

• Glue Strength to 1.0 (default)

• Point Method to Nearest (default) (Since the constraint 
locator is created in the middle of the bound hair, the 
locator is “nearest” the bound area to be constrained.)

4 Change the hair display to the Current Position.  (Hair > 
Display > Current Position)

5 Rewind to the start frame and play the simulation.

When the sphere passes through the bound curtain it collides 
with all the bound hairs. 

The bound part of the curtain relaxes within the first several 
frames, but in the next steps you reset the position of those 
Start curves so they look more natural at the beginning of the 
simulation.

See the constraint locator and the 
dotted lines that each represent the 
locator’s connection to the position on 
the affected curves
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To reset the Start position

1 Display the Start curves and the Current Position. (Hair > 
Display > Current and Start)

2 Rewind to the start frame and play the simulation.

3 Stop the simulation as soon as the curves relax below the 
constraint, but before the collision occurs.

4 Select the bound Start curves and then select Hair > Set Start 
Position > From Current. 

You may have to repeat steps 2 to 4 a few times until you are 
happy with the look of the bound curtains at the beginning of 
the simulation.
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Rendering the curtain scene
In these next steps you render the curtain, which is Paint Effects 
hair, in the Maya Software renderer. 

To render the Paint Effects hair using the Maya 
Software renderer

1 Modify the Render Globals settings for Paint Effects.

• Click the Render Globals  button on the Status Line. 
The Render Global Settings window appears.

• Select Maya Software from the Render Using drop-down 
list.

• In the Maya Software tab, go to the Paint Effects 
Rendering Options section and turn on Oversample and 
Oversample Post Filter. These help achieve a better look 
for the Paint Effects rendering.

• Click Close to close the Render Global Settings window.

2 Before rendering be sure to display the hair system’s Current 
Position. (Hair > Display > Current Position)

3 Play the simulation and stop at the frame you want to render.

4 Click the Render Current Frame  button on the Status 

Line. 

The curtain scene is rendered and should look something like 
the image below.
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Beyond the lesson
In this lesson you learned how to:

• Set up objects to collide with hair.

You can set up hair to collide with itself, the ground plane or 
other objects. You can even use the Collision Sphere and 
Collision Cube constraints to establish implicit collisions. For 
more information, see Making Hair Collide in the online Hair 
and Dynamic Curves guide.

• Assign a Paint Effects brush to a hair system.

This is useful for creating a variety of effects, such as vines or 
ivy for hair. The hair output can be Paint Effects or NURBS 
curves. For more information, see Assigning a Paint Effects 
brush to Hair in the online Hair and Dynamic Curves guide.

• Create constraints on hair curves.

Use hair constraints to hold hair in position for a hairstyle, 
such as a ponytail or a clasp. You can even use hair 
constraints for more realistic hair behavior, such as using the 
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Transform constraint to hold the hair to the head. For more 
information, see Setting up hair constraints in the online Hair 
and Dynamic Curves guide.
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Fluids are substances that change 
shape continuously or flow in 
response to forces.

Using Fluid Effects, you can 
realistically simulate 2D and 3D 
atmospheric effects (such as 
clouds and mist), combustion 
effects (such as smoke, explosions, 
and burning flames), and viscous 
fluid effects (such as molten lava).

You can also use the Fluid Effects ocean shader to simulate open 
water.

In Maya, there are three basic types of fluid effects:

• Dynamic fluid effects – Behave according to the natural laws 
of fluid dynamics and simulate the effects by solving fluid 
dynamics equations for each time step.

• Non-dynamic fluid effects – Use textures and animation to 
simulate fluid and fluid motion. These types of effects do not 
use fluid dynamics equations.

Dynamic and Non-Dynamic effects render as 3D volumes, so 
they interact appropriately with objects that move through 
them. 

• Open water fluid effects – Use shaders to create realistic wave 
motion on large bodies of water. 
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This chapter includes the following lessons, which introduce you 
to some basic Fluid Effects concepts:

• “Lesson 1: Creating a dynamic 2D fluid effect” on page 65

• “Lesson 2: Creating a non-dynamic 3D fluid effect” on 
page 77

• “Lesson 3: Creating a dynamic 3D effect” on page 89

• “Lesson 4: Creating an ocean effect” on page 101

Preparing for the lessons
To ensure the lessons work as described, do these steps before 
beginning:

1 Create a new scene.

2 Select the Dynamics menu set.

Unless otherwise noted, the directions in this chapter for 
making menu selections assume you’ve already selected the 
Dynamics menu set.

3 Switch to shaded display mode for a hardware render view of 
the fluid simulations (Shading > Smooth Shade All on the 
view menu bar).

4 In the Time and Range slider, set the start frame to 1 and end 
frame to 200.

5 Make sure you understand the basic usage of the animation 
playback controls. See the chapter entitled “Animation” in 
Getting Started with Maya or refer to the Maya Help.
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Lesson 1 Creating a dynamic 2D fluid effect

Fluid dynamics is a branch of physics that 
uses mathematical equations to describe 
how things flow. 

In Fluid Effects, dynamic fluid effects 
simulate fluid motion by solving fluid 
dynamics equations at each time step. 
You can texture dynamic fluids, have 
them collide with and move geometry, 
affect soft body geometry, and interact with particles. 

Non-dynamic fluid effects do not use the fluid dynamics equations 
to simulate fluid behavior. You create the look of a non-dynamic 
fluid using textures, and you create fluid motion by animating 
(keyframing) texture attributes. Because Maya doesn’t solve the 
equations, rendering this type of fluid is much quicker than 
rendering a dynamic fluid.

In this lesson, you create a simple 2-dimensional dynamic fluid. 
You learn how to:

• Create a fluid using fluid emitters.

• Modify the dynamic behavior of the fluid by applying forces 
to it and changing the effect the boundary has on the fluid.

• Change the color of the fluid.

• Collide the fluid into an object.

In the next lesson, you’ll create a non-dynamic fluid effect. 

Creating a 2-dimensional fluid container
You begin the lesson by creating a 2-dimensional fluid container. 
The fluid container is the basis for dynamic and non-dynamic 
fluid effects. As its name implies, it contains the fluid effect. Fluids 
cannot exist outside a fluid container.
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To create a 2-dimensional fluid container

• Select Fluid Effects > Create 2D Container. 

Maya creates an empty 2-dimensional fluid container centered 
at the origin in the XY plane.

Next, you add fluid to the container. To do this, you add 
values to the container for specific properties of the fluid: 
Density, Color, Velocity, Fuel, and Temperature. You can add 
any or all of these properties to create a fluid effect. One way 
to put properties into a container is to create them with a fluid 
emitter. 

Adding a fluid emitter to a container
Fluid emitters create fluid property values and emit them into 
containers as the simulation plays. The emitter controls the 
position, rate of emission, and turbulence forces applied to the 
fluid properties when they are created. After fluid property values 
are created, the attributes of the fluid container control their 
appearance and behavior. 

You can add multiple fluid emitters to containers. You move fluid 
emitters the same way you move any geometry (for example, by 
setting keys).
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To add a fluid emitter to the container

1 With the container selected, choose Fluid Effects > Add/Edit 
Contents > Emitter. 

Maya creates a fluid emitter called fluidEmitter1 and places it 
at the center of the fluid container. 

2 Play the simulation using the playback controls at the bottom 
of the Maya window.

The fluid emitter creates Density values and emits them into 
the container. 

Tip You can create a fluid container with a fluid emitter in 
one step using Fluid Effects > Create 2D Container with 
Emitter.

Fluid emitter
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The white in the container represents Density. Density is the 
substance of the fluid and the visible fluid property. Where 
the Density values are highest, the Density appears more 
opaque.

Notice that the Density rises to the top of the container and 
moves along the boundary of the container, eventually 
flowing down the sides. Forces built into the container are 
acting on the Density values, causing them to change. The 
fluid collides with the boundaries rather than penetrating 
them.

3 Stop the playback and go to the start of the playback range. 

Changing the behavior of a fluid
By modifying the attributes of the fluid container you affect the 
appearance and behavior of the fluid. Note that no matter what 
changes you make to the attributes, the fluid can never leave the 
container. 

In the next steps you’ll look at some of the attributes of the fluid 
container to gain some understanding into dynamic fluid effects.
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To modify attributes for the fluid 

1 Select the fluid container.

2 Show the Attribute Editor in the right panel of the Maya 
window, and click the fluidShape tab.

3 Look in the Contents Method section. The Contents Method 
defines how a fluid property is defined in the container, if at 
all. 

Notice that Density and Velocity are set to Dynamic Grid. 

A Dynamic Grid divides the container into rectangular units 
called voxels (volume pixels). You place the values in the grid 
by emitting them, painting them, or adding a predefined 
initial state. At each step of the simulation, Maya recalculates 
the values in each voxel using the fluid dynamics solver. This 
is what creates the dynamic motion of the fluid.

For dynamic fluid simulations, Density must be set to 
Dynamic Grid. Also, Velocity cannot be turned Off because 
velocity moves the property values around inside the grid.

Tip You can display Density values in the grid by changing 
Numeric Display to Density in the Display section of the 
fluid Attribute Editor.

Voxel

2D grid with Density Density values
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You look at defining properties as Gradient and Static Grid in 
the next lessons.

4 Make the density fall instead of rise:

• In the Attribute Editor, open the Dynamic Simulation 
section.

• Change the Gravity value to -9.8. (Acceleration due to 
gravity is -9.8 m/s2 in the physical world.)

• Negative values move the Density down.

• Play the simulation using the playback controls at the 
bottom of the Maya window.

5 Add turbulence to the container to give the Density a whirling 
circular motion. 

• Select the fluid container if it is not already.

• In the Attribute Editor, open the Contents Details section, 
and then open the Turbulence section.

• Change the Strength value to 1.0.

• Play the simulation using the playback controls at the 
bottom of the Maya window.
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6 Stop the playback and go to the start of the playback range.

7 Change the effect of the container boundaries on the fluid:

• In the Container Properties section at the top of the 
Attribute Editor, set the following options:

• Boundary X: None

• Boundary Y: None

8 Play the simulation using the playback controls at the bottom 
of the Maya window. 

Notice that the fluid no longer collides with the sides of the 
container—it appears to pass through the sides. The fluid 
behaves as though the container boundaries don’t exist. Note 
that even though the fluid appears to pass through the 
container boundaries, it does not exist outside the boundary. 
Fluids can only exist inside containers.
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9 Change Boundary X and Boundary Y back to Both Sides to 
restore the boundaries at all sides of the container.

10 Stop the playback and go to the start of the playback range.

Combining colors in a fluid
In the next steps, you’ll add another emitter to the container and 
make each emitter create different colored Density. You’ll see how 
different colored Density interacts in the container.

To combine colored fluids in the container

1 Select the fluid container and choose Fluid Effects > Add/Edit 
Contents > Emitter. 

Maya creates a second fluid emitter called fluidEmitter2 and 
places it at the center of the fluid container, in the same 
position as the first emitter.

2 With fluidEmitter2 still selected, select the Move Tool 
(Hotkey: w) and drag the emitter to the right of the container, 
so the emitters no longer overlap. 

Make sure you keep the emitter inside the container and on 
the plane by dragging only the X and Y manipulators. If you 
move the emitter outside the container, it will not emit.

3 Open the Attribute Editor in the right panel of the Maya 
window, and click the fluidEmitter tab.

4 In the Fluid Attributes section, turn on Emit Fluid Color. 

Drag only the X 
and Y 
manipulators to 
keep the emitter 
in the container.
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A message appears prompting you to set the fluid’s Color 
Method to Dynamic Grid. 

By setting the Color Method to Dynamic Grid, the color 
values you place in the container grid are recalculated by the 
fluid dynamics solver and changed during simulation. This 
means colors can interact during the simulation. 

5 Click Set to Dynamic.

6 Click the Fluid Color color box in the Attribute Editor.

The Color Chooser opens.

7 Select blue from the Color Chooser and click Accept.

8 In the scene view, select fluidEmitter1, the emitter in the 
center of the container.

9 In the Attribute Editor, turn on Emit Fluid Color for 
fluidEmitter1.

You are not prompted to set the contents method to Dynamic 
Grid, because you already set the container to Dynamic grid 
when you modified fluidEmitter2.

10 Click the Fluid Color color box.

The Color Chooser opens.

11 Select green from the Color Chooser and click Accept.

12 Play the simulation using the playback controls at the bottom 
of the Maya window.
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13 Stop the playback and go to the start of the playback range.

Colliding a fluid with an object
The 2D fluid you created is dynamic, so it can interact with 
objects. In the next steps, you’ll create a plane inside the fluid 
container and make the fluid collide with it, rather than pass 
through it.

To make the fluid collide with a plane

1 Create a polygon plane:

• Select Create > Polygon Primitives > Plane > . The 
Polygon Plane Options window opens.

• In the window, select Edit > Reset Settings to reset the 
plane settings to the default ones, and then click Create. 

2 In the Attribute Editor, click the pPlane1 tab and scale, 
translate, and modify the plane as follows:

• Translate: -2 2 0

• Rotate Axis: 0 0 40

• Scale: 10 1 1

3 Select both the plane and the fluid container. 

4 Select Fluid Effects > Make Collide. This makes the plane a 
collision object.
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5 Play the simulation using the playback controls at the bottom 
of the Maya window.

The fluid collides with the plane as it moves through the 
container. It does not pass through the plane.

Beyond the lesson
This lesson introduced you to some basic concepts of dynamic 
fluids. You learned how to:

• Create an empty fluid container.

• Emit fluid properties into the container to create a dynamic 
fluid effect.

• Modify forces acting on the fluid container to change the 
behavior of the contents of the container (Gravity and 
Turbulence).

• Add color to a fluid by emitting color into the container.

• Make a fluid collide with an object.

The hardware render of the simulation provided you with a fast, 
realistic representation of the fluid. The final step would be to do 
a software render.

Although we looked at a 2D fluid, the same concepts apply to 3D 
fluids. In the lessons that follow, you’ll work with 3D fluids and 
explore methods other than fluid emitters for adding contents to a 
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fluid container. You’ll look at the texturing capabilities that are 
part of the built-in shader. You’ll also learn about the 
Temperature and Fuel fluid properties and how you can use them 
in your effects.

Beyond this, you can also:

• Emit fluid from the surface of an object. 

• Give the fluid a hard surface (surface render) for a globby or 
lava-like effect, rather than the soft, cloud-like surface you 
saw in this lesson.

• Cache the fluid simulation for faster playback.

• Deform an object with the force of a fluid.

For details on these topics, see the Fluid Effects information in the 
Maya Help. 
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Lesson 2 Creating a non-dynamic 3D fluid 
effect

In the first lesson, you 
created a simple 2D dynamic 
fluid. 3D fluids intrinsically 
require extra data to define 
them, which can make them 
very complex. This extra 
data can slow a dynamic 
simulation exponentially 
because more calculations 
(solving) must be performed 
at every step of the simulation. For a less memory intensive effect, 
you could use a 2D fluid (with less data), or you could create a 3D 
non-dynamic effect. 

In non-dynamic fluid effects, the fluid property values are 
predefined within Maya and stay constant over time, which 
means they don’t have to be recalculated. You create the 
appearance of the fluid by texturing a special fluid shader that is 
assigned to the fluid. This shader is built into the fluid for better 
performance. If you want the fluid effect to have motion, you can 
animate (keyframe) the texture attributes. Because Maya doesn’t 
solve the fluid dynamics equations, rendering this type of fluid is 
much quicker than rendering a dynamic fluid.

In this lesson, you learn the fundamentals of creating non-
dynamic fluids by creating a cloud bank using a 3D non-dynamic 
fluid. You learn how to:

• Create a 3D fluid using predefined gradient contents.

• Texture the contents of the fluid using the built-in fluid 
shader.
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Before beginning the lesson, do the steps in ”Preparing for the 
lessons” on page 64.

Creating a 3D fluid container
Creating a fluid container is the first step in creating a non-
dynamic fluid effect. 

Fluid containers do not need to be uniform in X, Y, and Z. In fact, 
because larger fluids take longer to render, you should make 
containers only as large in each direction as necessary for the 
effect. A cloud bank sits above the ground like a blanket, so the 
container can be rectangular rather than cubic.

To create a 3D fluid container

1 Select Fluid Effects > Create 3D Container > .

The Create 3D Container Options window opens.

2 Set the container options as follows, then click Apply and 
Close:

• X Resolution: 50

• Y Resolution: 5

• Z Resolution: 60

• X Size: 50.0

• Y Size: 5.0

• Z Size: 60.0

The resolution is defined in voxels. Higher resolutions 
produce finer detail, but increase rendering time. The size of 
the container is defined in the working units set for Maya. The 
size of the fluid determines the size of each voxel.
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Maya creates an empty 3-dimensional fluid container centered 
at the origin. 

Next, you add fluid to the container. 

Adding fluid to a container
To make this a non-dynamic fluid, you add fluid property values 
to the container that will stay constant over time. There are two 
ways to do this: add these values to a static grid, or select a set of 
values from a list of predefined gradients that come with Maya. 
For this lesson, you’ll use the latter method.

For a cloud bank, Density is the only property you need to 
define—the other properties are typically used in dynamic 
solving.

To add fluid to the container 

1 Dolly the scene view to see the entire container

2 With the fluid container selected, show the Attribute Editor in 
the right panel of Maya, and click on the fluidShape1 tab.

Tip It’s good practice to make the container’s Resolution and 
Size proportional to ensure that the voxels are square 
making the quality the same along each axis.
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3 In the Contents Method section of the Attribute Editor, set:

• Density: Gradient

• Density Gradient: Constant

Set Velocity, Temperature, and Fuel properties to Off. 
(They’re not used in this effect.)

By setting the Density Gradient to Constant, you made all the 
Density values in the container the same—a value of 1. You 
can scale these values, but otherwise, they cannot change.

Defining shader attributes for a fluid
The fluidShape has a built-in shader that you can use to modify 
color, texture, and other attributes to give the fluid a particular 
look. In the next steps, you’ll make the shader apply specifically to 
the Density values inside the container.

To define shader attributes for the fluid

1 Open the Shading section in the Attribute Editor.

2 In the Color subsection, change Color Input to Density. 

The Density values in the container will now take on the 
colors defined on the color bar. Leave the color white to make 
the clouds appear white.

3 In the Opacity subsection, check that the Opacity Input is set 
to Density.
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The opacity represents how much the Density will block light. 
You’ll look more at Opacity later in this lesson. 

Texturing the contents of a fluid container
So far the container is filled with solid white Density. To create 
the cloud effect, you texture the Density so that some areas are 
transparent and some areas are opaque.

To texture the density of a fluid

1 Turn on hardware texturing display so you can see the effect 
of the textures on the fluid without rendering by selecting 
Shading > Hardware Texturing from the scene view menu.

2 Open the Textures section in the Attribute Editor.

3 Turn on Texture Opacity to apply the current texture to 
Opacity values. The current texture is Perlin Noise, defined by 
Texture Type.

Notice that the Density now has a slightly blotchy look to it, 
with areas that are more opaque and areas that are more 
transparent. This texture provides the standard 3D noise used 
in the 3D Solid Fractal texture included with Maya. 

4 Change Texture Type to Billow for a fluffy, cloud-like effect.

The Billow texture is computationally intensive and therefore 
slower than the other texture types.
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5 Change the look of the texture by setting the following texture 
attributes:

• Amplitude: 0.5

• Depth Max: 4

Decreasing the Amplitude makes the areas with low Density 
more transparent and the areas with high Density more 
opaque.

Increasing Depth Max adds detail. Increasing it will also 
increase render time.

6 Stretch the texture in the X direction by changing the X, Y, and 
Z components of the Texture Scale to 2, 1, 1. 
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7 Change the following Billow texture attributes to make the 
“billows” less dense, more spotty, and with randomly 
different sizes.

• Billow Density: 0.6

• Spottyness: 2.0

• Size Rand: 0.40

8 Modify the Opacity so that areas in the container that are very 
dense appear less opaque, areas that have very little Density 
become totally transparent, and the transition between areas 
that are totally transparent and areas that are more opaque is 
less gradual.
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In the Attribute Editor, go to the Shading section. Look at the 
Opacity graph in the Opacity subsection. This graph 
represents the relationship between Opacity values and 
Density values (the Opacity Input). 

Opacity values range from 0 on the bottom (totally 
transparent, no opacity) to 1 on the top (totally opaque).

Density values range from 0 on the left side (no Density) to 1 
on the right side (high Density).

So for the linear graph shown above, where Density values 
are 0, Opacity values are 0, making the Density totally 
transparent, where Density values are 0.5, Opacity values are 
0.5, making the Density partially opaque, and where Density 
values are 1, Opacity values are 1, making the Density totally 
opaque

• Click the first dot on the Opacity graph to select the position 
marker. Position markers mark the location on the graph from 
left to right (the Opacity Input value). The outline of the dot is 
white when a position is selected.

• Change Selected Position to 0.10 to change the position of the 
marker.

Opacity values

0 1

Opacity Input values 
(Density)

0

1

Click this dot to 
select the position 
marker
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The position marker moves to the right. Now, for Density 
values between 0 and 0.10, the Opacity values will be 0. This 
means that Density that was previously partially transparent 
will be completely transparent.

The more transparent areas of cloud disappeared, but now the 
solid areas of cloud are less opaque.

• Click on the graph to create a new position marker.

• Change the marker position and value as follows:

• Selected Position: 0.15

• Selected Value: 0.30

Click on the graph to create a 
new position marker
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Density values that are greater than 0.15 are now more 
opaque, and the transition between areas of total transparency 
(Opacity 0), and areas where the Density becomes more 
visible (Density 0.15) is less gradual.

Adding self shadowing to texture density
Give the clouds some depth by adding self shadowing. Self 
shadowing causes the fluid to cast shadows on itself using a 
single internal directional light at -1, -1, -1.

To add self shadowing to the texture density

1 In the Attribute Editor, under the fluidShape1 tab, open the 
Lighting section.

2 Turn on Self Shadow.
Getting Started with Maya Unlimited

86



3 | Fluid Effects
Lesson 2 > Fluids Lesson 2: Beyond the lesson
The clouds now have some darker areas on them, giving them 
some depth.

3 In the Display section, change Boundary Draw to None to 
hide the container. This gives you a better idea of how the 
fluid will look before you render it.

Fluids Lesson 2: Beyond the lesson
This lesson showed you a basic technique for creating non-
dynamic fluids. While creating the effect, you learned how to:

• Create a 3D fluid container of a specific resolution and size.

• Add predefined gradient contents to the container to create a 
non-dynamic fluid.
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• Texture the contents of the fluid using the built-in fluid 
texturing capabilities of the fluidShape. (You can also texture 
dynamic fluids using the same techniques.)

To make the texture move, you would keyframe the Texture Time 
attribute in the Textures section of the Attribute Editor. For details 
on keyframing attributes, see the Maya Help.

You modified several texture attributes in this lesson, but there 
are many more attributes for customizing textures. Also, note that 
the non-dynamic effects you can create using texturing are not 
limited to clouds. Here are some examples:

To learn more about how to use texturing and other fluid 
attributes, study the Fluid Effects examples that are included with 
Maya (Fluid Effects > Get Fluid Example) and look at the Notes 
section at the bottom of the Attribute Editor for example fluids. It 
includes information about the selected effect, pointing out the 
key aspects of its construction. In addition to these examples, a 
growing collection of examples are available from the Alias 
community web site. Visit this site regularly for new examples. 
For further information on Fluid Effects, see the Maya Help.
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Lesson 3 Creating a dynamic 3D effect

In the real world, gasoline reacts 
chemically with oxygen at a certain 
temperature, creating flames (light, heat) 
and the gaseous products of combustion. 
Over time, the gasoline burns until it’s 
totally consumed. You can simulate this 
situation in Fluid Effects using Fuel, 
Density, and Temperature properties.

In this lesson, you create a dynamic 
explosion effect by filling the bottom of a container with Fuel and 
Density, then “igniting” it with Temperature. You learn how to:

• Add property values to a container by painting them.

• Paint in a 3D container.

• Use Fuel, Density, and Temperature to create an explosion 
effect.

Before beginning the lesson, do the steps in ”Preparing for the 
lessons” on page 64.

Creating a 3D container
1 Select Fluid Effects > Create 3D Container > .

The Create 3D Container Options window opens.

2 In the window, select Edit > Reset Settings to restore the 
Resolution and Size settings to the defaults 10 10 10 and 10 10 
10, respectively.

The default container size and resolution are adequate to 
illustrate the concepts in this lesson.

3 Click Apply and Close. 

Maya creates an empty 3-dimensional fluid container centered 
at the origin. 
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Next, add fluid to the container. In the first lesson, you added 
fluid to the container by emitting it into a Dynamic Grid. In 
the second lesson, you added fluid to the container by 
selecting a predefined gradient. In this lesson, you will add 
fluid to the container by painting property values inside it.

Painting Fuel and Density into a container
In Fluid Effects, Fuel defines the state of a reaction (unreacted, 
completely reacted, and states in between). Density represents the 
substance that is reacting, while Temperature causes the reaction. 
Combining Density with Fuel defines a situation in which you can 
see a reaction. You add Temperature to this situation to start the 
reaction. As the reaction takes place, Density values become 
smaller and the Fuel values get smaller to represent how much of 
the reaction has yet to take place. The reaction also creates more 
Temperature, and it creates light.

In the following steps you’ll paint Fuel and Density values in the 
container. To paint in a 3D container you actually paint in two 
dimensions on “slices” of the container. A slice is a plane in X, Y, 
or Z that represents where you paint. (You could think of a slice 
as a 2D canvas.) You paint each slice individually, but the 
accumulative effect of adjacent slices is a 3D fluid.
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To paint Fuel and Density into a container

1 With the container still selected, choose Fluid Effects > Add/
Edit Contents > Paint Fluids Tool > . 

The Tool Settings window opens and a slice displays at the origin 
of the fluid container. The slice is represented by a plane with 
dotted edges and fluid subvolume manipulators at one corner. 
When you move the pointer over the slice the pointer changes to a 
brush indicating that you can paint. 

2 At the top of the Tool Settings window, click Reset Tool to set 
the Paint Fluids Tool settings to the default values.

3 Select the fluid properties you want to paint. In the Paint 
Attributes section of the Tool Settings window, beside 
Paintable Attributes, select Density and Fuel. You will paint 
both these properties at the same time. 

You could paint each property separately, but for this 
example, the values you paint will be the same for both. It is 
more efficient to paint them both at the same time.

A message appears prompting you to set the fluid’s Fuel 
method to Dynamic Grid. By setting the Fuel method to 
Dynamic Grid, the fuel values you place in the container grid 
(in this case, by painting them) are recalculated by the fluid 
dynamics solver and changed during simulation. The Density 
method is defined as Dynamic Grid by default.

Brush
Subvolume 
manipulators

Slice
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4 Click Set to Dynamic.

5 Tumble the scene and look at the slice and manipulators. 

The orientation of the slice changes relative to your view. The 
slice is perpendicular to the axis with the manipulators. The 
color of the manipulators corresponds with the color of the 
axis in the View or Origin axes. 

Painting properties relative to different axes is good practice 
to ensure there are no gaps between slices when the fluid is 
viewed from different angles. 

6 Tumble so that the slice is perpendicular to the Y axis and 
then click the open lock icon to lock the slice axis.

The lock closes. Now when you tumble, the slice remains 
perpendicular to Y. It does not switch to the other axes. This 
allows you to change the view in any way and still be able to 
paint on the same slice.

Click to lock the axis...
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7 Drag the top move arrow down along the axis to the first slice 
at the bottom of the container. The number of slices along 
each axis corresponds with the resolution of the fluid 
container. The numbering starts at 0 at the intersection of the 
axes. For this container the resolution is 10 10 10, so the slices 
are numbered from 0 to 9. 

The help line displays the location of the selected slice.

Fluid Slice Location: 0.000 

8 In the Paint Attributes section of the Tool Settings window, 
ensure that Value is set to 1. A Fuel value of 1 represents a 
totally unreacted state while a Fuel value of 0 represents a 
completely reacted state. A Density value of 1 is totally 
opaque while a Density value of 0 is completely transparent.

9 Drag the brush on the slice to paint values. Paint until the 
entire slice is filled with values. 

Drag down to 
move the 
slice...

...to Fluid Slice 
Location: 0.000
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The values display as yellow because you are painting two 
properties at the same time. Density values are represented by 
the opacity of the shaded values, while Fuel values are 
represented by color. The range of Fuel values corresponds 
with a ramp of colors from blue (values of 0) to yellow (values 
of 1).

To make the fluid deeper, you could move the slice to Fluid 
Slice Position 1, paint, move the slice to Fluid Slice Position 2, 
paint, and so on. But a quicker way is to resize the slice to 
make it thicker and then flood the entire slice with values. 

10 Resize the paint slice, making it thicker:

• Click the target icon once to switch to the subvolume 
scaling mode. 

The slice becomes thicker and the manipulator changes to 
include scaling boxes at the ends of the move arrows. 

• Click the top scaling box and read the help line to 
determine that the Fluid Slice Thickness is 3.00. You could 
drag the scaling boxes to change the thickness of the slice, 
but the slice is thick enough for the lesson.

11 In the Tool Settings window, click the Flood button.

Click target icon...

Scaling boxes

Thicker slice
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Flooding filled each voxel in the subvolume with Fuel and 
Density values of 1.

Notice that the values display as shaded planes rather than as 
a solid mass. This is an interactive display feature for shaded 
display mode. Displaying more shaded planes (slices) 
produces more detail but reduces the speed of the screen 
draw. You can change this display feature (Slices Per Voxel) 
and others in the Display section of the Attribute Editor.

Now that the container has Density and Fuel in it, you are 
ready to start a reaction by adding Temperature. You could 
think of this as putting a lit match into a container of gasoline.

Shaded plane
(slice)
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Painting Temperature values into a container
By default, the Fuel and Density will react when there is no 
Temperature in the container, but adding higher temperature 
values will make the reaction more immediate.

To paint Temperature values into a container

1 In the Tool Settings window, beside Paintable Attributes, 
select Temperature. A message appears prompting you to set 
the fluid’s Temperature method to Dynamic Grid or Static 
Grid. 

By setting the Temperature method to Dynamic Grid, the 
temperature values you place in the container grid are 
recalculated by the fluid dynamics solver and changed during 
simulation. 

By setting the Temperature method to Static Grid, the 
temperature values you place in the container grid are used 
by the fluid dynamics solver during the simulation, but they 
cannot change during the simulation. Static Grid is useful 
when you want to define specific values in specific areas of 
the container, but you do not want these values to change 
over time.

2 Click Set to Dynamic. The Density and Fuel values disappear. 
The values are still there, but only Temperature values now 
display. Currently there are no temperature values in the 
container.

3 Change the brush so you can paint through the entire 
thickness of the slice with a single stroke. In the Stroke section 
of the Tool Settings window, change Stamp Depth (3D) to 2. 
The brush changes, showing how deep the brush stroke will 
paint. 
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If you make the brush depth thicker than the depth of the 
slice, only the space within the slice will be painted. 

4 Paint a small amount of Temperature in the center of the slice.

The stroke adds Temperature values through the entire 
thickness of the slice.

The next steps are to view all the property values together, 
and color the properties to differentiate them.

Adding color to Density and Temperature
Use the built-in shader to modify the color of Density and 
Temperature in the container.

To add color to the Density and Temperature

1 Choose the Select Tool (Hotkey: q) to leave the Paint Fluids 
Tool. The manipulators disappear and now you see the fluid 
as it will render 

Brush depth
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2 With the fluid container selected, open the Attribute Editor.

3 Change the color of the fluid as follows:

• In the Shading section of the Attribute Editor, expand the 
Color section, and change Color Input to Density.

• The Density values in the container will now take on the 
colors defined on the color bar. 

• Click the Selected Color box. The Color Chooser opens.

• Select black in the Color Chooser and click Accept.

The Density turns black. 

Look closely at the center of the fluid. The area where you 
painted Temperature has a reddish orange color. In the 
Incandescence section of the Attribute Editor, notice that 
Incandescence Input is set to Temperature. Temperature gives 
Getting Started with Maya Unlimited

98



3 | Fluid Effects
Lesson 3 > Beyond the lesson
off light and Incandescence controls the amount of light 
emitted from regions of Density due to self illumination. The 
ramp defines the color of this light. 

4 Play the simulation using the playback controls at the bottom 
of the Maya window.

By frame 160, most of the Density values have reacted 
completely.

Beyond the lesson
This lesson introduced you to the Fuel and Temperature fluid 
properties. You learned how to:

• Combine Fuel, Density, and Temperature to create a dynamic 
explosion effect.

• Add property values to a container by painting them.
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• Paint in a 3D container.

You can control how quickly the reaction takes place during the 
simulation, the temperature required to start the reaction, how 
much heat and light the reaction releases over time, and other 
aspects of the reaction using the attributes in the Fuel section 
under Contents Details in the fluidShape Attribute Editor.

For a more realistic look, you can also texture the fluid using the 
built-in texturing attributes in the Textures section.

For more information on Fuel and texturing attributes, see Fluid 
Effects in the Maya Help.
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Lesson 4 Creating an ocean effect

An ocean effect is defined by 
a plane with an ocean shader 
assigned to it. Ocean effects 
are not created with fluid 
containers like the dynamic 
and non-dynamic fluid effects 
you created in the first three 
lessons.

A shader is a collection of 
attributes that define color 
and other surface 
characteristics of the plane it is assigned to. For an ocean shader, 
these attributes define realistic waves on large bodies of water.

In this lesson, you create an ocean, put a cube in it, and see how 
the cube floats in the ocean. You learn how to:

• Create an ocean plane and shader.

• Create a preview plane to see the effects of the shader, 
including displacement, without rendering.

• Modify the ocean shader attributes to make the waves bigger.

• Make an object a boat in the scene.

• Modify the attributes for an expression that controls the 
buoyancy of the boat in the ocean.

Before beginning the lesson, do the steps in ”Preparing for the 
lessons” on page 64.
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Creating an ocean plane and shader
Fluid Effects simplifies the process of creating an ocean by 
providing a single command that creates a plane that is optimized 
for best results, and an ocean shader with appropriate connections 
to the plane.

To create an ocean plane with ocean shader

1 Select Fluid Effects > Ocean > Create Ocean. Maya creates an 
ocean plane and assigns an ocean shader to it.

2 Dolly out to see the plane.

The plane is a NURBS plane with more patches concentrated in 
the center. This is so you can see more detail in the center and less 
detail as the ocean extends to the horizon. 

Because interactive shading would slow down playback, the 
shading is turned off for the surface. 

Adding a preview plane to an ocean
Because shading is turned off for the ocean plane, you need a 
preview plane to see displacement and shading in the hardware 
render. Displacement changes the surface of the ocean plane so 
you can see the different wave heights.
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To add a preview plane to the ocean

1 Dolly back in to the center of the plane.

2 Select Fluid Effects > Ocean > Add Preview Plane. 

Maya creates a preview plane that interactively shows the 
displacement of the ocean on a shaded patch of ocean. You 
can scale and translate it to preview different parts of the 
ocean. This plane does not appear in renders. 

3 With the preview plane still selected, choose the Scale Tool 
(Hotkey: r) and make the patch bigger by dragging the center 
scale box to the right. Make it approximately 25 times bigger. 
(Look at the scaling numbers in the help line.)

4 Play the simulation using the playback controls at the bottom 
of the Maya window.
Getting Started with Maya Unlimited

103



3 | Fluid Effects 
Lesson 4  > Modifying ocean attributes
The preview plane ripples slightly showing the small wave 
displacement. 

5 Light the scene to prepare it for rendering later in the lesson:

• Select Create > Lights > Directional Light. Maya creates a 
directional light called directionalLight1 at the center of 
the grid. 

• Open the Attribute Editor and in the Directional Light 
Attributes section of the directionalLightShape1 tab, 
change Intensity to 2 to make the light brighter.

• Click the directionalLight1 tab and rotate the light as 
follows to direct the light rays onto the ocean.

Rotate: -100 42 20

Modifying ocean attributes
In the next steps, you will modify ocean shader settings to make 
the waves bigger.

To modify attributes for the ocean shader

1 Render the current frame to see what the ocean looks like 
before you modify the ocean shader attributes. On the Status 
line, click the render current frame icon. ).
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2 Select the preview plane or the ocean plane (it doesn’t matter 
which one), and in the Attribute Editor, click the 
oceanShader1 tab.

3 Open the Ocean Attributes section and change the following 
values:

• Num Frequencies: 12

• Wave Length Max: 40

Num Frequencies controls the number of frequencies between 
minimum and maximum wave lengths. Increasing this value 
results in a more textured look on the water surface.

Wave Length Max controls the maximum length of waves in 
meters. Longer wave lengths make bigger waves.

4 Play the simulation to see the effect of your changes on the 
displacement of the ocean waves.

5 Stop the playback and go to the start of the playback range.

6 Render the current frame.
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7 Make the tops of the waves form crests by adjusting the Wave 
Peaking graph in the Attribute Editor.

Wave Peaking controls the amount of crest formation for 
waves across the range of wave frequencies. It simulates a 
side-to-side sloshing of waves, as opposed to an up-down 
motion. Wave Peaking is only applied to turbulent waves 
(where Wave Turbulence is not zero). 

Click on the graph to create the position markers shown in the 
next illustration.

Click...

...to create position markers
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Where the wave frequency is lower, the waves peak more.

8 Render the current frame.

The tops of the waves now crest slightly. 

Notice the white highlights on the ocean. These are specular 
highlights caused by the light hitting the water. 

9 Make the highlights dimmer so they don’t pop out as much, 
and bigger. Open the Specular Shading section and change the 
following settings:

• Specularity: 0.45

• Eccentricity: 0.1

Specularity controls the brightness of the specular highlights. 
Higher values create brighter highlights. 

Eccentricity controls the size of the specular highlights. 
Higher values create bigger highlights.

10 Render the current frame.
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Floating objects
You can make geometry (for example, a boat) float in the ocean, 
moving appropriately with the motion of waves. The following 
steps show you how using a simple polygon cube.

To float a cube in the ocean

1 Create a polygon cube. (Select Create > Polygon Primitives > 
Cube.)

2 In the Attribute Editor, click the pCube1 tab and scale the 
cube as follows:

• Scale: 10 10 10
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3 Select both the cube and the ocean plane (not the preview 
plane) at the same time and select Fluid Effects > Ocean > 
Make Boats. 

Maya creates a boat locator at the center of the cube to mark 
the cube’s position in space. The locator is connected to a 
predefined expression that simulates buoyancy effects. The 
expression is connected to the wave heights (displacement) of 
the ocean.

To learn more about expressions, look at the Expressions 
lessons in Getting Started with Maya.

4 Play the simulation using the playback controls at the bottom 
of the Maya window.

The cube bobs, pitches and rolls in the ocean.

5 In the Attribute Editor, click the locatorShape2 tab and in the 
Extra Attributes section, modify the following options. These 
serve as inputs to the expression. 

• Buoyancy: 0.75

• Roll: 0.1

• Pitch: 0.2

Increasing Buoyancy makes the box float more and sink into 
the ocean less. Decreasing the Roll and Pitch values causes the 
cube to roll less from side to side, and pitch less forwards and 
backwards as a result of the wave motion.
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Beyond the lesson
In this lesson, you learned that ocean effects are different from the 
dynamic and non-dynamic volume fluid effects. An ocean effect is 
created with a plane and shader rather than a container and fluid 
properties. With ocean effects you learned how to:

• Create an ocean plane and shader.

• Create a preview plane to see the displacement of the shader 
without rendering.

• Modify ocean shader attributes to customize the look of the 
ocean.

• Make geometry bob and move in the ocean.

To learn more about ocean shader attributes, look at the ocean 
shader examples that are included with Maya (Fluid Effects > Get 
Ocean/Pond Example). Some of these examples use a 3D non-
dynamic volume fluid to create the atmosphere above the ocean. 

Motor Boats

You can create a game-style boat simulation using the Fluid 
Effects > Oceans > Make Motor Boats command. Once you set up 
hotkeys for the rudder and throttle of the boat, you can “drive” 
the boat in the ocean. The boat will roll, pitch, and jump over 
waves appropriately.

Boat Wakes

You can create boat wakes using the Fluid Effects > Oceans > 
Create Wakes command. Wake fluids do not use the Navier 
Stokes solver like regular fluids, but use the Spring Mesh Solver. 
A fluid emitter is used to drive the motion of the fluid.
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Ponds

If a smaller body of water is what you had in mind, you can create 
a pond using Fluid Effects > Pond > Create Pond. Ponds are 2D 
fluids that use a spring mesh solver and a height field. You can 
generate bubbles, ripples, and waves using the Create Wake 
options for the pond.

For details on these topics and others, see Fluid Effects in the 
Maya Help.
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4 Cloth
With Maya’s Cloth feature, you can 
model garments and simulate 
natural cloth behavior on an 
animated 3D character. You can also 
apply dynamic effects such as wind 
or turbulence to the cloth. In 
addition to creating clothing for 
characters, you can create and 
animate sheets, bedding, drapery, 
flags, and other fabric goods.

This chapter includes these lessons:

• “Lesson 1: Making a Shirt” on 
page 118

• “Lesson 2: Making Pants” on 
page 134

• “Lesson 3: Exporting & 
Importing Garments” on 
page 144

About cloth animation
To create and animate clothing, you do the following general 
steps:

• Posing and animating a character

• Constructing a garment

• Fitting a garment onto a character

• Animating the cloth

Image courtesy of Sony 
Pictures Imageworks. 
Columbia/TriStar.
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Posing and animating a character

Before you construct a garment, you 
position the character in a dress-up pose 
at the scene’s start frame. The dress-up 
pose minimizes wrinkling and other 
undesired effects when you fit the 
garment. 

You animate the character to create the 
transition from the dress-up pose to its 
starting position, for instance, to the 
first step of a walk cycle. A typical 
duration for the transition is 20 frames—longer if the starting pose 
differs significantly from the dress-up pose. Finally, you complete 
the character’s animation from the starting pose onward. 

Constructing a garment

When you begin creating a garment, 
you use the surface of your 3D 
character as a mannequin, much like 
a tailor uses a mannequin. Using the 
dress-up pose as a guide, you draw 
curves to form the outline of a 
garment. From these curves you 
create panels. The panels are similar to 
actual fabric patterns that are sewn 
together to make a finished garment. 
When you seam the panels together, 
you create a garment.
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Fitting a garment onto a character

To fit the garment, you make the 
character a collision object, then run a 
cloth simulation for a single frame—
the dress-up pose frame. As the 
simulation runs, the garment drapes 
onto the character. Subtle 
adjustments to the garment’s position 
occur continuously as the simulation 
runs. You stop the simulation at a 
desirable position, then save the 
position as the initial position.

You can use constraints and dynamic fields to influence the 
settling of the cloth. For example, you can pull out wrinkles or pin 
portions of the garment to specific places on the character. You 
can set various attributes of the cloth to change the physical 
behavior of the cloth. 

You can also create different types of fabric and affect the physical 
behavior of the garment. You can use different fabrics in the same 
garment, such as a baseball jacket with leather sleeves. 

Animating the cloth

First, you play the animation from the 
dress-up pose to the animation start 
pose. This runs the simulation for the 
frames played, which animates the 
garment’s motion along the way. You 
do this to create a natural look for the 
garment at the beginning of the 
animation segment you’re creating. 

Next, you change the frame range to 
span only the animation segment you 
will render, not the frames from the dress-up pose to the 
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animation start pose. You won’t use the positioning of the 
garment prior to this point, so you save its current position for use 
at the start of the new frame range. 

You play the animation to run the simulation of the cloth’s motion 
for the desired animation segment. To enhance the results, you 
run the simulation several times with various attribute settings. 
You can modify the garment’s appearance and motion using 
constraints, dynamic forces, or keys. 

Lesson workflow

In many production groups, it’s typical for an animation specialist 
to animate the character in one scene while a cloth specialist 
constructs and fits the garments to a copy of the character in 
another scene. The fitted garments are then exported to the 
animation scene, where the cloth specialist positions them on the 
character and runs the cloth simulation for the animation. 

The following lessons use this workflow. In the first two lessons, 
you drape a shirt and pants on a stationary 3D character. In the 
last lesson, you import a shirt and pants into a scene containing an 
animated version of the same 3D character. You position the shirt 
and pants on the character, then run a cloth simulation that causes 
the cloth to wrinkle and deform as the character moves. Because 
the lessons collectively illustrate a complete cloth workflow, it’s 
best to do them in the order presented. 

Keep in mind that, in your own work, you can create the 
garments and animate the character in a single scene. 

Preparing for the lessons
To ensure the lesson works as described, do these steps before 
beginning:

1 Make sure you understand basic concepts of polygonal 
modeling, animation, and character setup. 

2 Select the Cloth menu set.
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If Cloth doesn’t appear in the menu set selection menu, select 
Window > Settings/Preferences > Plug-in Manager. In the 
Plug-in Manager window, click the loaded checkbox for 
CpClothPlugin.so (IRIX, Linux) or CpClothPlugin.mll 
(Windows). Close the Plug-in Manager window. Maya loads 
Cloth and adds the Cloth menu set. 

Unless otherwise noted, the procedures in this book assume 
the Cloth menu set is selected. 

3 Select Window > Settings/Preferences > Preferences. Click the 
Timeline category and set Playback Speed to Play every 
frame. This setting is necessary for the cloth simulation to 
work correctly. Click the Save button.

4 Obtain the Cloth lesson data from the Maya Documentation, 
Lessons, and Extras CD. You can either copy the following 
directory from the CD or work from it directly:

UnlimitedLessonData/Cloth/scenes

We provide a completed scene for each of the lessons in this 
chapter. If you want to see the expected results of the lessons, 
you can open the scenes from UnlimitedLessonData/Cloth/
scenes on the Maya Documentation, Lessons, and Extras CD or 
from the drive where you copied the Getting Started with 
Maya Unlimited data files. The scene filenames end with 
Final.mb, for instance, importFinal.mb.
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Lesson 1 Making a Shirt

Creating a cloth garment in 
Maya has many similarities to 
making a real piece of clothing. 
One similarity is that you need 
to start with a flat pattern of 
your garment. In this lesson, you 
learn how to create a shirt and 
fit it onto a stationary character. 
You learn how to:

• Create panels from closed 
curves.

• Create a polygonal mesh garment from panels.

• Define a property for a garment that defines its behavior 
when it moves.

• Run a simulation to position and shape a garment on a 
character model.

• Modify attributes to make a garment drape more naturally. 

Lesson setup
In this lesson, you work with a scene we created for your use.

1 Before beginning the lesson, do the steps in ”Preparing for the 
lessons” on page 116.

2 Open the scene named shirtStart.mb.

3 You can open the scene named shirtStart.mb from the Maya 
Documentation, Lessons, and Extras CD or from the drive where 
you copied the Getting Started with Maya Unlimited data 
files. The file is located in UnlimitedLessonData/Cloth/
scenes.
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This scene provides a polygonal model, named jackie, and the 
curves for creating the panels of the shirt. The curves for the 
front and back panels are planar and form closed boundaries. 
This is important to remember when creating curves for your 
panels.

Creating panels
In the next steps, you’ll create panels to be assembled as a shirt.

To create the front vest panel

1 In the Outliner, open the shirtPattern group. 

2 Select curvesBack and press Ctrl-h to hide the curves.

You’ll work only with the front curves for the next several 
steps, so it’s helpful to hide the back curves to reduce clutter 
in the scene.

Note that the grey color of jackie’s wireframe indicates that 
jackie is displayed as a template, which is an object that is 
visible, but not selectable in the view. We made jackie a 
template so you can’t select it unintentionally.

3 In the Outliner, select and hide jackie (Ctrl-h) to reduce clutter 
in the scene. 

4 Select the curves that represent the front vest part of the shirt. 
You can select the curves in any order. If you want to use the 
Outliner, open the curvesFront group and select curve1 
through curve5 and curve9 through curve13. 
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The curves form a closed loop and lie in the same plane. The 
end of one curve is where the next curve begins. Curves must 
meet these requirements to be used for creating a panel.

5 Select Cloth > Create Panel

The Cloth Panel icon is displayed, indicating you’ve created a 
panel.

To create the front sleeve panels

1 Select the curves for the right sleeve and create a panel. (In the 
Outliner, these are curve3, and curve6 through curve8.)

Front panel

Panel icon

Right sleeve
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2 Select the curves for the left sleeve and create a panel. (In the 
Outliner, these are curve11, and curve 14 through curve16.)

3 In the Outliner or view, select panel1, panel2, and panel3. 

4 Select Edit > Group to group the panels. 

5 Name the group panelsFront in the Channel Box, then 
parent panelsFront under shirtPattern by middle-dragging 
panelsFront over top of shirtPattern in the Outliner.

We provided shirtPattern group in the scene to help you 
organize your curves and panels. Grouping and parenting 
objects in this way is not necessary when creating a garment. 
However, organizing the elements of your garment makes it 
easier to locate them in the Outliner if the need arises. 
Grouping also makes it easy to hide or display a number of 
related elements.

To create the back vest panel

1 Hide panelsFront and curvesFront by selecting 
Display > Hide > Hide Selection, as you won’t be working 
with them for awhile.

2 In the Outliner, select curvesBack and select Display > Show > 
Show Selection. You’ll use these curves to create the back part 
of the shirt.

3 Select the curves that represent the back vest part of the shirt. 
To use the Outliner, open the curvesBack group and select the 
following curves using the Ctrl key with your left mouse 
button to select:

• curve17 through curve20

• curve24 through curve27

• curve31

4 Select Cloth > Create Panel to create a panel.
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To create the back sleeve panels

1 Select the curves for the right sleeve. To use the Outliner, 
select curve18 and curve21 through curve23. Select Cloth > 
Create Panel.

2 Select the curves for the left sleeve. To use the Outliner, select 
curve25, and curve28 through curve30. Select Cloth > Create 
Panel. You now have three panels for the back of your shirt. 

3 Group the three panels and name the group panelsBack in 
the Channel Box.

4 For the sake of scene organization, parent panelsBack under 
shirtPattern by middle-dragging panelsBack over top of 
shirtPattern in the Outliner.

Creating a garment
Now that you’ve created all the panels, you’re ready to create the 
garment. A garment is a collection of panels.

To create a garment

1 Select Display > Show > Show Cloth > All. This displays all 
curves and panels that exist in the scene.

2 In a perspective view, rotate the camera so you can see the 
front and back panels. 

3 Select the middle front panel, being careful not to select a 
curve in addition.
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4 Select Cloth > Create Garment.

This creates a polygonal mesh garment named cloth1. It also 
creates a stitcher node, called cpStitcher, which lets you create 
seams between panels.

5 Press the 5 key to see the panel in smooth shaded mode. 

6 In the Channel Box, click on cpStitcher and set the Base 
Resolution to 200.

.

This tessellates the cloth into smaller subdivisions. The higher 
the Base Resolution, the finer the tessellation. Finer 
tessellation means the surface allows finer shape alterations. 
The lower the Base Resolution, the faster the processing. As 
with other attributes described in this lesson, experience will 
guide your choice of values.

7 In the Outliner, change the name of cloth1 to shirt by double-
clicking on the name.

Seaming panels in a garment
To include all panels of the shirt in the garment, you seam them to 
a panel in the garment. Currently the garment has only one 
panel—the middle front panel. When you seam a panel that’s not 
in the garment to a panel in the garment, the new panel is added 
to the garment and the mesh is tessellated again. You can seam a 
panel only to a panel in the garment. You cannot seam to a panel 
that’s not in the garment. 
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You create seams much like you would sew seams in a shirt 
pattern. You create side seams, shoulder seams, and sleeve seams. 
If two panels share a curve, for instance, a front sleeve panel and 
the adjacent front vest panel, you pick the curve between them 
and create a seam. 

If two panels do not share a curve, for instance, a back sleeve 
panel and a front sleeve panel, you select the appropriate pair of 
edge curves and create the seam. The technique will become clear 
in the following steps.

To seam the panels in the garment

1 Display the panel in wireframe mode. (Click in the view and 
press 4.)

2 In the Outliner, open the curvesFront and curvesBack groups. 

3 Select curve11 and select Cloth > Create Seam. This seams 
together two panels that share the same curve. 

4 In the Outliner, select the single curve or pair of curves listed 
below, then select Cloth > Create Seam to seam the panels 
together. 

Selection Action

curve3  . Create Seam

Create 
seam here
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As you do this, observe how the resulting seams and panels 
differ based on which curve or curves you select. After you 
finish creating the seams, you can display all seams by 
selecting Display > Show > Show Cloth > Seams. The icons for 
seams between panels resemble stitches or ruler marks. A 
single row of stitch marks exists for a seam made between 
panels that share a curve. Two separated rows of stitch marks 
exist for a seam made between panels that do not share a 
curve, one row at each of the curves selected before you 
created the seam.

The easiest way to know if you’ve seamed the entire garment 
is to examine the garment in shaded mode. The garment will 
have no unintended gaps between the panels. 

curve6  curve21 Create Seam

curve18 . Create Seam

curve25 . Create Seam

curve8  curve23 Create Seam

curve2  curve17 Create Seam

curve4  curve19 Create Seam

curve10  curve24 Create Seam

curve14  curve28 Create Seam

curve15  curve29 Create Seam

curve12  curve26 Create Seam

Selection Action
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Creating and editing a property for a garment
Cloth properties define how the cloth behaves as it moves, 
whether during the simulation or as the underlying object is 
animated. By default, each panel is connected to a property called 
cpDefaultProperty. However, you can create as many properties as 
you want and apply any property to any panel.

To create and edit a property for the garment

In the next steps, you’ll create a property for the shirt and edit a 
pair of the many attributes available.

1 In the Outliner, select all the panels, but not the panelFront or 
panelBack group nodes.

2 Select Simulation > Properties > Create Cloth Property. This 
creates a new property node and assigns it to the selected 
panels.

3 In the Channel Box, rename cpProperty to cpPropertyShirt.

4 Set the U Bend Resistance and the V Bend Resistance 
attributes to 5.0.

These attributes control how much the cloth resists flexing. 
The default value is 10. Lower values increase the flexibility of 
the cloth. In this lesson, you use the same value for both 
attributes so the cloth resists flexing uniformly. 

In some situations, it’s useful to set the two attributes to 
different values to make the cloth flex more in one surface 
direction than the other. To know which surface direction is U 

Tip To see which property node affects a panel, select the 
panel, and in the Channel Box you’ll see the property 
node listed under INPUTS.
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and which is V, examine the v notch in the panel icon. The v 
notch points in the V direction. U is perpendicular to the V 
direction.

Making a 3D character a collision object
To have cloth interact with a surface, you must make the surface a 
collision object before you run the simulation. A collision object 
can be a polygonal or NURBS surface. If you use a NURBS 
surface, Maya calculates the collision as if it were a polygonal 
surface. In the next steps, you’ll make jackie a collision object. 
(Jackie is a polygonal object.)

To make the 3D character a collision object

1 In the Outliner, select jackie. 

2 From the main menus, select Display > Show > Show 
Selection to display jackie.

3 Untemplate jackie by selecting Display > Object Display > 
Untemplate. This will let you see the cloth deform against 
jackie’s surface more clearly. 

4 With jackie still selected, select Cloth > Create Collision 
Object.

5 In the Channel Box, set Collision Offset to 0.2. 

This specifies how far Maya strives to keep the cloth away 
from the collision object during the simulation. It’s likely that 
parts of the garment will pass slightly through the Collision 
Offset distance occasionally during the simulation. When the 
garment pokes through, Maya repels the garment back above 
the surface again. 

If a garment pokes through too much or too often, increase 
the Collision Offset and run the simulation again.

6 In the Channel Box, set Collision Depth to 0.7.
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The Collision Depth sets the maximum distance any part of 
the cloth can penetrate the collision object and still be repelled 
back above the surface of the collision object. 

If a garment passes the Collision Depth threshold, the 
collision object won’t repel the cloth and allows it to pass 
through entirely. If this occurs, try a higher Collision Depth 
value and run the simulation again. Set the Collision Depth to 
a value no larger than half the depth of the collision object. In 
this context, depth means the distance between any opposing 
surfaces of the collision object. 

Running a cloth simulation
Running a simulation refers to the processing that Maya does to 
position and shape the cloth on the collision object. The part of 
Maya that performs the simulation is the cloth solver. It assembles 
information on the cloth, any bodies it interacts with, and any 
fields or constraints applied to the cloth. Before you run the 
simulation, you’ll set the Solver Scale attribute to enhance the 
realism of the shirt’s deformation during the simulation.

To run the cloth simulation

1 In the Outliner, select shirtPattern and press Ctrl-h to hide the 
seams.

2 In the Outliner, select shirt.

3 In the Channel Box, click cpSolver1 and set Solver Scale to 10.

The scene view size of the garment and 3D character 
influences the way a garment behaves. For instance, a tiny 
shirt hangs differently than a giant shirt. 

Jackie is about 16 grid units (centimeters) in height. To make 
the cloth behave as a real-life shirt, you need to increase the 
Solver Scale to compensate for its small size. A value of 10 
causes Maya to process the cloth as if it were positioned on a 
model 160 centimeters tall—roughly the size of a real person.
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4 Go to the start time. Otherwise, after you run the simulation, 
the cloth will return to its original undraped position when 
you go to the start time.

5 To run a simulation, select Simulation > Start Local 
Simulation. 

This relaxes (drapes) the shirt to the 3D character. The cloth 
wiggles slightly long after it snugs up against the character. 
This occurs because the cloth solver continuously recalculates 
the position of the cloth against the collision object in case any 
new movement or force influences the objects.

6 When the cloth settles into a desirable position, press Esc to 
stop the simulation.

If you are using Maya on IRIX or Linux, press Esc when you 
are satisfied with the shirt’s appearance. If you are using a 
Windows workstation, select Simulation > Stop Simulation 
rather than press the Esc key.

You can use Undo to return the garment to its pre-simulation 
state.

Draped State
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Increasing a garment’s resolution
In the next steps, you’ll run the simulation a few times after 
setting higher values for the garment’s Base Resolution 
(tessellation). The garment drapes more naturally at a higher 
resolution, but processing takes longer. By running the simulation 
a few times with increasing resolution, the simulation times are 
shorter and the cloth deforms more smoothly.

To increase the Base Resolution for the garment

1 Select the shirt and display the Attribute Editor. 

2 Click the cpStitcher1 tab.

3 Turn on Fit to Surface. 

Note If you play the scene, Maya runs the simulation for the 
entire animation time range, by default. As time 
changes, the cloth’s motion is cached so you can later 
scrub the Time Slider to examine the cloth’s appearance 
at various frames. The animation plays faster after 
caching because Maya uses disk-stored cloth positions 
for each frame. 

If you decide to see the results of the simulation with 
different attribute settings, you must first delete the 
cache by selecting Delete Cache from the Simulation 
menu. Generally, you run the simulation by playing the 
animation only after you’ve draped the garment onto a 
stationary character with Simulation > Start Local 
Simulation.

With Simulation > Start Local Simulation, animation 
time does not advance. You use a local simulation to 
drape the garment onto a stationary character. 
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After you’ve run a simulation, it’s necessary to turn on Fit to 
Surface before you change the Base Resolution of a garment, 
add seams, or modify the shape of a panel by editing its 
original curves. Otherwise, the garment’s shape distorts. 

4 Set the Base Resolution to 300. 

5 Select Simulation > Start Local Simulation. When the shirt 
relaxes, press Esc.

6 Set the Base Resolution to 400. 

7 Select Simulation > Start Local Simulation. When the shirt 
relaxes, press Esc.

Changing the Collision Offset
Now you decrease the Collision Offset and run the simulation 
again. This brings the shirt closer to the skin.

To decrease the Collision Offset for the simulation

1 Select jackie.

2 In the Channel Box, set the Collision Offset to 0.1. 

3 Select Simulation > Start Local Simulation.

4 When the shirt relaxes, press Esc.

High resolution cloth
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5 To see what the cloth looks like with a shader applied, you 
can assign it a material that we created for your use in the 
lesson.

• Select the shirt. Select the Rendering menu set. Select 
Lighting/Shading > Assign Existing Material > shirtMtl. Press 
5 to turn on smooth shading.

Beyond the lesson
The behavior of cloth is controlled primarily by attributes in the 
collision object’s shape node and by the cpSitcher, cpSolver, and 
cpProperty nodes. Most attributes that affect cloth, such as Shear 
Resistance, require experimentation to find the best setting.

Additional things to know when you create cloth patterns and 
garments: 

• Planning your curves and panels is critical to creating good 
cloth in Maya.

This lesson provided curves already shaped into the outline of 
a shirt. Many of the panels shared a single curve across a 
seam. A good practice is to ensure that curves are not shared 
across a seam so that each panel has a unique set of closed 
boundary curves. Shared curves were used in this lesson for 
the sake of simplicity.
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Before you draw the curves, you must consider the shape of 
the panels you plan to create. In general, it’s necessary to 
create a panel for each part of the garment that you want to 
look or behave uniquely. For instance, to create a woolen 
jacket with leather sleeves, the sleeves need to be panels 
separate from the vest. For help in planning panels, consider 
looking at real fabric patterns online, at the library, or in a 
fabric store.

When you create your own curves for clothing, position the 
curves close to the body without intersecting it. You position a 
group of curves in front of the model and another in back of 
the model as shown in this lesson. If you modify the original 
curves after you create a garment, the garment updates 
automatically.

• Simulation options affect the final result.

When you work on your own garments, it’s best to start by 
running the simulation with default option settings. Later, 
you run the simulation a few times with different settings 
until you achieve the garment look you’re seeking. 
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Lesson 2 Making Pants

In this lesson, you make a pair of 
pants and fit it onto a stationary 
character. You also learn how to 
refine specific panels of the pants. 
In this lesson you learn how to:

• Duplicate a set of curves for a 
pattern.

• Create front and back panels for 
the garment.

• Set the solver and property 
attributes for a cloth simulation.

• Refine the simulation using the 
Base Resolution attributes.

Lesson setup
In this lesson, you work with a scene we created for your use.

1 Before beginning the lesson, do the steps in ”Preparing for the 
lessons” on page 116.

2 Open the scene named pantsStart.mb.

3 You can open the scene named pantsStart.mb from the Maya 
Documentation, Lessons, and Extras CD or from the drive where 
you copied the Getting Started with Maya Unlimited data 
files. The file is located in UnlimitedLessonData/Cloth/
scenes.

This scene includes jackie’s model and some curves you’ll use 
to make the pants. We provided the curves so you can focus 
on developing a garment rather than on creating curves. The 
model has been templated to make picking curves easier.
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This lesson does not explain concepts and menu items described 
in the prior lesson. If you don’t understand a term in this lesson, 
see the prior lesson.

Creating panel curves
The scene you just opened includes the curves for half a pair of 
pants. In the next steps, you’ll duplicate the curves for the other 
half of the pants. Later in the lesson, you’ll create panels from the 
curves and seam the panels together to form the pants.

To create the front curves

1 In the Outliner, note the pantsPattern group. This group 
includes two groups: curvesBack and curvesFront. Hide the 
curvesBack group because you won’t work with them until 
later.

2 Open the curvesFront group so that all the curves in it are 
listed.

3 Select curve2 through curve9.

4 Select Edit > Duplicate 
> . From the options 
window, select 
Edit > Reset Settings, then 
continue as follows.

• Set Scale for the X-axis 
to -1.

When you complete the 
Duplicate operation in a 
later step, the duplicate 
curves will be created in 
corresponding positions 
along the negative X-axis. This mirrors the left leg in the right 
leg position.
Getting Started with Maya Unlimited

135



4 | Cloth 
Lesson 2  > Creating front and back panels
• For Geometry Type, turn on Instance.

Instancing the curves makes modifying the pants easier; if 
you adjust the left leg, the right leg is adjusted identically.

• Click the Duplicate button.

5 Hide the curvesFront group. You won’t work with them until 
later.

To create the back curves

1 In the Outliner, select the 
curvesBack group. Select 
Display > Show > Show 
Selection.

2 In the Outliner, open the 
curvesBack group so that 
all the curves in it are 
listed.

3 Select curve12 through 
curve19.

4 Select Edit > Duplicate. 
This uses the same 
Duplicate options that you used before. (Scale for the X-axis is 
-1, Geometry Type is Instance).

5 Hide the curvesBack group.

Creating front and back panels
In the next steps, you’ll create panels to be assembled as pants. 

To create the front panels

1 Select jackie in the Outliner then hide jackie to reduce scene 
clutter (Ctrl-h).
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2 Display curvesFront in the scene view. (Select it in the 
Outliner and select Display > Show > Show Selection.) With 
the curves in curvesFront, you can create five panels: one 
waistband panel, two hip panels, and two leg panels.

3 In the Outliner, select the curves below, then select Cloth > 
Create Panel.

4 Group the panels and name the group 
panelsFront.

5 Parent panelsFront under the pantsPattern group. Grouping 
parts of the garment simplifies finding them in the Outliner if 
the need arises.

6 Hide panelsFront and curvesFront. You won’t use them in the 
next steps.

To create the back panels

1 Display curvesBack in the scene view.

2 In the Outliner, open the curvesBack group to list the curves. 
Select the following curves in the Outliner, then select Cloth > 
Create Panel. 

Selection Action

curve3, 4, 5, 21, 22, 23 Cloth > Create Panel

curve1, 2, 3, 6 Cloth > Create Panel

curve1, 20, 21, 24 Cloth > Create Panel

curve6, 7, 8, 9 Cloth > Create Panel

curve24, 25, 26, 27 Cloth > Create Panel
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3 Select panel6 through panel10. 

4 Group the panels and name the group panelsBack.

5 Parent panelsBack under the pantsPattern group.

Creating a garment
In the next steps you create a garment from one of the panels so 
that you can then seam the other panels to the garment. The panel 
you use to create the initial garment is arbitrary.

To create the garment

1 Select Display > Show > All.

2 In the Outliner, open the panelsFront group to list the front 
panels.

3 Select panel4. Select Cloth > Create Garment.

4 In the Outliner, rename cloth1 as pants.

5 With pants still selected, click cpStitcher in the Channel Box. 
Set the Base Resolution to 250.

Seaming panels in a garment
Now you’ll seam the remaining panels into the garment.

Selection Action

curve16, 18, 19, 32, 34, 
35

Cloth > Create Panel

curve11, 15, 16, 17 Cloth > Create Panel

curve11, 31, 32, 33 Cloth > Create Panel

curve12, 13, 14, 17 Cloth > Create Panel

curve28, 29, 30, 33 Cloth > Create Panel
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1 In the Outliner, open the curvesFront and curvesBack groups 
to list the curves. In the Outliner, select the single curve or 
pair of curves listed below, then select Cloth > Create Seam to 
seam the adjacent panels together.

Selection Action

curve6 Cloth > Create Seam

curve3 Cloth > Create Seam

curve21 Cloth > Create Seam

curve1 Cloth > Create Seam

curve24 Cloth > Create Seam

curve8,14 Cloth > Create Seam

curve2,15 Cloth > Create Seam

curve4,18 Cloth > Create Seam

curve17 Cloth > Create Seam

curve16 Cloth > Create Seam

curve7,12 Cloth > Create Seam

curve11 Cloth > Create Seam

curve32 Cloth > Create Seam

curve33 Cloth > Create Seam

curve25,28 Cloth > Create Seam

curve26,30 Cloth > Create Seam

curve20,31 Cloth > Create Seam

curve22,34 Cloth > Create Seam
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2 Press 5 to smooth shade the pants. The garment will have no 
holes or gaps between the panels if you’ve seamed all the 
panels.

Increasing the resolution of panels
You can increase the resolution of specific panels to have regions 
of the garment deform more precisely than others during the 
simulation.

To increase the resolution of panels that affect the 
waistband 

1 Select panel1 and panel6. These are the two panels that 
control the shape of the waistband. 

2 In the SHAPES section of the Channel Box, set the Resolution 
Factor to 1.7. With the increased resolution, the waistband 
becomes smoother.

Creating a collision object 
To have the pants interact with jackie, you must make jackie a 
collision object before you run the simulation.

To create the collision object for the simulation 

1 Hide pantsPattern.

2 In the Outliner, select jackie and select Display > Object 
Display > Untemplate.

3 With jackie selected, select Cloth > Create Collision Object.

4 In the Channel Box, set Collision Offset to 0.1 and Collision 
Depth to 0.5.

Running and modifying a simulation
In the following steps, you’ll run the simulation repeatedly with 
various option settings. 
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To set the solver and property options

Solver and property attributes control how the pants deform 
during the simulation.

1 Select Simulation > Solvers > cpSolver1 >  to display the 
solver attributes.

The Attribute Editor appears.

2 Set the Solver Scale to 10.

3 Select Simulation > Properties > 
cpDefaultProperty > .

4 Set U and V Bend Resistance to 
20.

5 You can optionally deselect jackie 
so that the surface is easier to see.

6 Select Simulation > Start Local 
Simulation.

7 When the pants fit well, press the 
Esc key to stop the simulation.

Do not be concerned if there are 
small spots where jackie pokes 
through the pants. You’ll fix this at the end of the lesson.

To add and edit properties for specific panels

In the next steps you’ll assign a property to selected panels, then 
set property attributes that affect the behavior of the panels.

1 Select Display > Show > Show Cloth > Panels.

2 Select panel1 and panel6, in the Outliner. These are the two 
waistband panels.

3 Select Simulation > Properties > Create Cloth Property.
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This creates a new property node and assigns it to the selected 
waistband panels.

4 In the Channel Box, rename the cpProperty node to 
cpPropertyBelt, then set the U Scale to 0.8.

The U Scale value of 0.8 scales down the waistband panel in 
the U direction, which causes the cloth in the waistband to 
tighten. This takes effect only after you run the simulation 
again.

5 Select the two panels at the rear, panel7 and panel8 in the 
Outliner.

6 Select Simulation > Properties > Create Cloth Property and 
name the property cpPropertyRear.

7 In the Channel Box settings for cpPropertyRear, set the U and 
V Scale to 1.1. When you run the simulation, the cloth in the 
rear of the pants will fit a bit more loosely.

8 Select Simulation > Start Local Simulation. When the pants fit 
well, press the Esc key.

Increasing the Base Resolution

You might have noticed small 
regions where jackie pokes through 
the pants. This is a common when 
you run a simulation for a garment 
with relatively coarse tessellation. In 
the next steps you’ll eliminate the 
interpenetration by increasing the 
tessellation of the pants.

1 In the Outliner, select the pants.

2 In the Attribute Editor, click the 
cpStitcher tab. 
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3 Set the Base Resolution to 300 and turn on Fit To Surface.

4 Select Simulation > Start Local Simulation.

5 When the pants fit well, press the Esc key.

If you want to see what the cloth looks like with a shader 
applied, you can assign it a material we created for your use 
in the lesson.

6 Select the pants. Select the Rendering menu set. Select 
Lighting/Shading > Assign Existing Material > pantsMtl to 
assign the material to the pants.

7 Press 5 to turn on smooth shading.

Beyond the lesson
In this lesson you learned that:

• The process for creating pants is roughly the same as for 
creating a shirt.

• Creating panels for your garments has a specific procedure 
for best results.

• The process of fitting a garment might require several 
iterative simulations.

• The Base Resolution affects the detail of the cloth as well as 
the interpenetration between objects.

• Regardless of the type of garment you create, you can have 
specific panels look and behave differently when simulated.

Interpenetration is a common result of using a low Base 
Resolution. However, it’s best to start with a low Base Resolution 
because the simulation runs faster. By increasing the Base 
Resolution slightly with subsequent simulations, you’ll spend less 
time waiting for lengthy simulations. Using repeated simulations 
after making small adjustments to option settings is also beneficial 
because it reduces the chance of the garment looking unnatural.
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Lesson 3 Exporting & Importing Garments

In the previous lessons, you fitted the cloth 
garments to a character that was positioned in 
a rest pose. In production settings, a cloth 
garment may be fitted on one version of a 
character while another version is being 
animated. It is useful to know how to export 
the garment from one scene to another.

In this lesson, you export the pants and shirt 
from previous scenes and import them into a 
scene containing an animated jackie. In the 
scene, jackie animates from a dress-up pose to 
a complete walk cycle. You position the shirt 
and pants on jackie and run the simulation of 
the cloth for the entire frame range. In this 
lesson you learn how to:

• Export and import cloth garments between scenes.

• Position the garments between solvers.

• Transfer garments between solvers.

• Apply mesh constraints to keep garments in place.

• Adjust the garments for a better fit.

Exporting garments
You’ll begin the lesson by exporting a shirt and pants. If you 
completed the prior lessons, the shirt and pants will look familiar. 
Before beginning, do the steps in ”Preparing for the lessons” on 
page 116.

This lesson does not explain concepts and menu items described 
in the prior lessons. If you don’t understand a term in this lesson, 
see the prior lessons.
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To export the shirt

1 Open the scene named shirtFinal.mb.

You can open the scene named shirtFinal.mb from the Maya 
Documentation, Lessons, and Extras CD or from the drive where 
you copied the Getting Started with Maya Unlimited data 
files. The file is located in UnlimitedLessonData/Cloth/
scenes. 

The scene contains a shirt that was created by running a 
simulation on jackie.

2 Select the shirt. Make sure nothing else is selected. 

3 Select File > Export Selection > . From the options window, 
select Edit > Reset Settings, make sure History is turned on, 
then click Export Selection.

With History on, Maya exports the cloth solver that controlled 
the shirt’s simulation in shirtFinal.mb. You must include 
the solver because you’ll run the simulation of the shirt again 
in the scene where you import it. In scenes where you don’t 
plan to redo simulation of an imported garment, such as a 
stationary tablecloth, you can leave History turned off to 
avoid importing the solver.

4 Do one of the following, depending on your operating system:

• (Windows) In the Export Selection window, click the 
down arrow in the top box to display the pull-down 
menu and select Current scenes. 

• (IRIX, Linux) In the Export Selection window, select File > 
Go to Current scenes. 

5 Enter the name shirtExport and click Export. This creates a 
scene file named shirtExport.mb.
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To export the pants

1 Open the scene named pantsFinal.mb.

You can open the scene named pantsFinal.mb from the Maya 
Documentation, Lessons, and Extras CD or from the drive where 
you copied the Getting Started with Maya Unlimited data 
files. The file is located in UnlimitedLessonData/Cloth/
scenes. 

The scene contains a pair of pants that was created by running 
a simulation on jackie.

2 Select the pants. 

3 Select File >Export Selection. 

This export operation uses the same options you set the last 
time you used File > Export Selection > . 

4 Do one of the following, depending on your operating system:

• (Windows) In the Export Selection window, click the 
down arrow in the top box to display the pull-down 
menu and select Current scenes. 

• (IRIX, Linux) In the Export Selection window, select File > 
Go to Current scenes. 

5 Enter the name pantsExport and click Export. This creates a 
scene file named pantsExport.mb.

To open the animation scene

1 Open the scene named importStart.mb.

You can open the scene named importStart.mb from the 
Maya Documentation, Lessons, and Extras CD or from the drive 
where you copied the Getting Started with Maya Unlimited 
data files. The file is located in UnlimitedLessonData/Cloth/
scenes.
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Notice that jackie has the same dress-up position and scale as 
in the export scenes. This is a requirement for importing 
exported garments. In this scene, however, jackie has been 
moved and rotated away from the origin. In this lesson, you’ll 
move and rotate the imported garments to fit them properly 
on jackie. 

2 Make sure the frame range is -20 to 118.

3 Play the scene to become familiar with the animation.

In frames -20 to 1, jackie makes a transition from the dress-up 
pose to the start position of the walk cycle. In frames 1 to 118, 
jackie is animated in a walk cycle.

4 Go to the start time of the animation (frame -20). 

To import the shirt

1 Select File > Import > . From the options window, select 
Edit > Reset Settings, turn on Use Namespaces, then click the 
Import button.

The option settings cause Maya to rename all imported 
objects, solvers, and other nodes so they cannot clash with 
existing names in the scene. 

2 Do one of the following, depending on your operating system:

• (Windows) In the Import Selection window, click the 
down arrow in the top box to display the pull-down 
menu and select Current scenes. 
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• (IRIX, Linux) In the Import Selection window, select File > 
Go to Current scenes. 

3 Select shirtExport.mb and click Import. This imports the 
shirt. 

4 In the Outliner, select shirtExport:shirt.

In the Channel Box, notice the names shirtExport:cpSolver1 
and shirtExport:cpStitcher1. Because of the options you 
selected in the Import options window, Maya added 
shirtExport: as a prefix to the cpSolver1 and cpStitcher1 nodes 
that were imported from the shirtExport.mb file. This 
ensured that the names would be unique after being imported 
to importStart.mb.

Positioning an imported garment
The imported shirt is positioned at the origin. You need to 
position the shirt on jackie.

To position the shirt on the character

1 Move and rotate the shirt so it fits well on jackie. Press 5 to 
turn on smooth shading so you can see where the shirt 
penetrates the skin.

A perfect fit is not necessary. Running the simulation will 
push out the shirt. However, make sure the positioning is 
close to the following values:

• Translate X: 9.93
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• Translate Y: 0.1

• Translate Z: -9.98

• Rotate Y: -24

2 In the Channel Box, click shirtExport:cpSolver1. Set the Start 
Frame to -20 in the INPUTS section of the Channel Box. When 
you run the simulation, it will start from frame -20.

3 From the Cloth menu set, select Simulation > Save as Initial 
Cloth State.

Maya will use the current shirt position and shape at the start 
of the animation (frame -20).

Creating a collision object for an imported 
garment
You need to make jackie a collision object so the shirt drapes on 
jackie when you run the simulation.

To create a collision object

1 Select jackie.

2 Select Cloth > Create Collision Object.

3 In the Channel Box, set the Collision Offset to 0.16 and the 
Collision Depth to 0.2. 

Ignore Warning: Cycle on joint... messages after you 
make jackie a collision object. To prevent such messages, enter 
cycleCheck -e off in the Command Line.

To run the simulation

1 Select Simulation > Start Local Simulation. 

Within a minute or so, the shirt drapes nicely on jackie 
without interpenetration. Press Esc when you are satisfied 
with the shirt’s display.

Next, you’ll import the pants and position them on jackie.
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To import and position the pants

1 Hide the shirt. The name of the shirt is shirtExport:shirt.

2 Select File > Import. The importing will occur with the same 
options used when you imported the shirt. 

3 Do one of the following, depending on your operating system:

• (Windows) In the Import Selection window, click the 
down arrow in the top box to display the pull-down 
menu and select Current scenes. 

• (IRIX, Linux) In the Import Selection window, select File > 
Go to Current scenes. 

4 Select pantsExport.mb and click Import. This imports the 
pants. 

5 Move and rotate the pants on jackie so they fit as well as 
possible. The pants are named pantsExport:pants. A suitable 
position is at:

• Translate X: 10

• Translate Y: 0 
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• Translate Z: -10

• Rotate Y: -30

6 With the pants selected, click pantsExport:cpSolver1 in the 
Channel box. Set the Start Frame to -20. When you run the 
simulation, it will start from frame -20.

7 Select Simulation > Save as Initial Cloth State.

Maya will use the current position and shape of the pants at 
the start of the animation (frame -20).

Importing solvers
When you imported the shirt and pants, Maya also imported a 
pants solver and a shirt solver. The names of the solvers, 
pantsExport:cpSolver1 and shirtExport:cpSolver1, are listed under 
the menu Simulation > Solvers >.

Currently, the solvers have no effect on the pants and shirt 
because you have not connected them to jackie in this scene. (The 
solvers were previously connected to a different jackie in the 
exported scenes.)

In the next steps, you’ll make jackie a collision object that interacts 
with the pants during simulation. You’ll also run a simulation to 
correct jackie’s interpenetration of the pants.

To create a collision object for the pants

1 Select Simulation > Solvers > pantsExport:cpSolver1. This 
makes the pantsExport:cpSolver1 solver the current solver. 

2 Select jackie.

3 Select Cloth > Create Collision Object. 

4 Select the pants.
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Selecting the pants specifies which solver you want to use. 
Even though shirtExport:cpSolver1 has no effect because it’s 
not connected to jackie, you must still select the pants to make 
pantsExport:cpSolver1 operate when you run the simulation.

If a scene has two or more solvers, only one can operate at a 
time during a local simulation. Selecting the pants specifies 
which solver operates. (You need to do this even if one of the 
solvers is not connected.)

To run the simulation for the pants

1 Select Simulation > Start Local Simulation. 

2 Press Esc when you are satisfied with the pants.

Transferring solvers
For the shirt to drape over the pants and not just jackie, both 
garments need to be connected to the same solver. To do this, 
you’ll transfer the pants to the shirt’s solver. Be aware that if two 
garments do not touch and you do not expect them to touch 
during an animation, they don’t need to share a solver.
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To transfer the pants solver to the shirt

1 Select Simulation > Solvers > shirtExport:cpSolver1.

This makes the shirt’s solver current.

2 With the pants selected, select Simulation > Transfer Garment.

This transfers the pants to the shirt’s solver. To confirm that 
the pants are controlled by the shirt solver, check that 
shirtExport:cpSolver1 is displayed in the INPUTS section of 
the Channel Box.

3 In the Command Line, enter:.

delete pantsExport:cpSolver1

This deletes the pants solver, which is no longer needed. 

Adding mesh constraints
To prevent the pants from sliding down as jackie walks, you’ll use 
mesh constraints to hold the pants on jackie’s waist. This works 
like a belt.
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To add a mesh constraint for the 
pants

1 Select jackie and select Display > 
Object Display > Template.

2 Right-click over the pants and select 
Vertex.

3 Select the top row of vertices on the 
pants. Use Shift-select to add vertices 
to the selection (or to remove vertices).

4 In the Outliner, Ctrl-click jackie. This 
adds jackie to the selection without 
deselecting the vertices.

5 Select Constraints >Mesh to create the 
mesh constraints. Mesh constraint 
icons appear on the pants, showing 
where the pants are constrained to 
jackie.

6 Hide the mesh constraints. Because the mesh constraints are 
currently selected, you can hide them by pressing Ctrl+h. In 
case you want to display the constraints later, be aware that 
the mesh constraints are indented under pantsExport:pants. 

Manually adjusting garments
Next, you have Maya drape the shirt over the pants without 
interpenetration.

To manually adjust the shirt

1 Untemplate jackie.

2 Show (unhide) the shirt.

Notice the pants poking through the shirt.

3 Hide jackie to reduce screen clutter.
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4 Template the pants so you can’t pick any of its vertices.

5 With the pointer over the shirt, right-click and select Vertex 
from the marking menu.

6 Select all vertices that overlap the pants and additionally a 
small band of nonoverlapping vertices above the pants. If you 
can’t see the overlapping region clearly, press 4 for wireframe 
display, then dolly into the view.

7 Use the Move and Scale tools to move the vertices away from 
the pants with plenty of clearance. Avoid creating sharp edges 
on the surface of the shirt.

8 Select the shirt and select Simulation > Update Cloth State.

This updates the solver with the new positions of the vertices. 
This is essential for the next simulation to work correctly.

9 Select Simulation > Properties > shirtExport:cpPropertyShirt 
> . Enter a Thickness of 1.5 and a Thickness Force of 3.5.

The Thickness specifies the collision offset of the cloth when it 
collides with itself and other cloth objects. Thickness Force 
sets how much force Maya uses to maintain the Thickness 
collision offset during cloth-to-cloth collisions. The default 
values for Thickness and Thickness Force are 0.2 and 1. The 
higher values you use in this step help keep the shirt further 
away from the pants when you run the simulation.

Move vertices 
outward
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10 Show jackie and untemplate the pants.

11 With the shirt selected, select Simulation > Start Local 
Simulation.

If you are using Maya on IRIX or Linux, press Esc when you 
are satisfied with the shirt’s appearance. If you are using a 
Windows workstation, select Simulation > Stop Local 
Simulation rather than press the Esc key.

After the simulation, if the shirt is in a position where it 
penetrates the pants, select Edit > Undo to return the shirt to 
its previous position. In the area where the shirt moved under 
the pants, move the vertices further away from the pants. 
Then select the shirt, Simulation > Update Cloth State, and 
Simulation > Start Simulation.

Running a simulation for an animation 
sequence
In the next steps, you run the simulation from the dress-up pose 
to the beginning of the walk cycle. You do this to create a natural 
look for the pants and shirt at the beginning of the walk cycle. 
Later, you’ll run the simulation for the walk cycle.

To run the simulation for the first part of the 
animation

1 In the Time Slider, set the end time to 1 and make sure the 
start time is -20.

2 Select Simulation > Solvers > shirtExport:cpSolver1 > . Set 
the following attributes:

• Start Frame: -20

• Frame Samples: 2

• Relax Frame Length: 0
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The Frame Samples value sets how 
often the solver does cloth 
calculations during the simulation. 
Higher values increase precision but 
with longer processing.

By default, a simulation is a two-part 
process. First, the solver fits the 
garments to the character without the 
effect of gravity. Second, it fits the 
garments with the addition of 
gravity.

The Relax Frame Length value 
specifies the length of time that Maya 
fits the garment to jackie before 
gravity’s effect begins. Generally, the 
larger the number of frames, the 
closer the fit. Because the gravity alone will fit a shirt to the 
character suitably, you set the Relax Frame Length to 0. 

3 Select the shirt. Select Simulation > Delete Cache. 

Whenever you change cloth properties or other attributes that 
affect the garment, you must delete the cache before you run 
the simulation. Otherwise the results of the simulation won’t 
reflect your changes.

4 Select Window > Settings/Preferences > Preferences. Click the 
Timeline category. Set Looping to Once then click Save.

With Looping set to Once, Maya doesn’t needlessly play the 
animation after you run the simulation.

5 Go to the start of the playback range and play the animation.

Playing the animation runs the simulation from frame -20 to 1. 
At frame 1, the shirt and pants lie naturally on jackie at the 
beginning of the walk cycle. 

Walk cycle start pose
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Saving the initial state for garments
In the preceding steps, you created the desired look of the pants 
and shirt at the start of the walk cycle. In the next steps, you’ll 
save the current positioning of the pants and shirt as their position 
at the start time of the animation.

To save the initial state for the shirt and pants

1 Select the shirt.

2 Select Simulation > Save as Initial Cloth State.

3 Select the pants.

4 Select Simulation > Save as Initial Cloth State.

Now you’ll run the simulation for the walk cycle.

To run the simulation for the walk cycle

1 Set the Time Slider’s start and end times to 1 and 118. This is 
the frame range where you’ll run the simulation.

2 Select Simulation >Solvers >shirtExport:cpSolver1 >  and set 
the Start Frame to 1. This value specifies the frame at which 
the solver starts the simulation during playback.

3 Select Simulation > Delete Cache.

4 Play the animation. This runs the simulation for the walk 
cycle.

After the simulation runs, the cloth’s motion is cached, so you 
can scrub the Time Slider to evaluate the look of the cloth at 
various frames. Playback is also faster.

If you decide to simulate again with different attribute 
settings, you must first delete the cache. Otherwise, scrubbing 
and playback will use the cloth motion from the prior 
simulation.
Getting Started with Maya Unlimited

158



4 | Cloth
Lesson 3 > Eliminating interpenetration
Note that when you cache a cloth simulation, the directory 
where the scene exists will contain a file with the extension 
.mcc, for example, pantsFinal.mcc. This file contains the 
caching information for the scene. If you no longer use the 
cache for a scene, you can delete the file.

Eliminating interpenetration
If you examine the garments closely at various frames, you might 
see spots where jackie penetrates the pants or where the pants 
penetrate the shirt. Eliminating the problem requires 
experimentation.

Try one of the following solutions, then select Simulation > Delete 
Cache and play the animation. If the interpenetration problem 
persists, try another solution, delete the cache, and play the 
animation again.

To solve interpenetration problems

• Select jackie and increase the Collision Offset a small amount, 
for instance, from 0.16 to 0.17.

• For interpenetration between the pants and shirt, select 
Simulation > Properties > shirtExport:cpPropertyShirt > . 
Increase the Thickness and Thickness Force a small amount. 
For example, change Thickness from 1.5 to 1.6, and change 
Thickness Force from 3.5 to 3.7.

• Select the garment that has been penetrated. In the Attribute 
Editor, click the garment’s cpStitcher tab. Increase the Base 
Resolution a small amount, for instance, from 300 to 330, and 
make sure Fit To Surface is turned on. Increasing the Base 
Resolution slows the simulation considerably.

As a quick fix to a few frames before rendering, you can drag 
vertices of a garment into a satisfactory position and simply 
render the offending frames.
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Beyond the lesson
In this lesson you learned how to:

• Transfer garments between scenes using Import and Export.

• Apply mesh constraints to garments.

• Manually adjust the polygonal mesh of a garment for a better 
fit.

• Set cloth states for the garments.

• Run a cloth simulation for an animated walk cycle.

In this lesson, you ran the simulation once for the transition from 
the dress-up pose to the start of the walk cycle, and once for the 
walk cycle. The reason you split the simulation into two parts was 
to avoid repeating simulation of completed frames needlessly. 

Your goal for running a simulation up to the start of the walk 
cycle is to have the shirt and pants look natural in their initial 
position where the character begins the walk cycle. After you’ve 
accomplish this, there’s no need to simulate the prior frames 
again. When you run the simulation for the walk cycle, you 
typically need to experiment with various attribute values and 
run the simulation several times. 

Other cloth features

The Maya Help provides additional information on other features 
of cloth. For instance, you can:

• Use the mouse or tablet stylus to paint cloth stiffness, 
wrinkling, and other effects. 

• Use constraints and dynamic fields to influence the way the 
garment drapes on the character. For example, you can pull 
out wrinkles or you can pin portions of the garment to places 
on the character. 

• Set various attributes to create different types of fabric that 
affect the behavior of the garment. 
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• Use different fabrics in the same garment, such as a baseball 
jacket with leather sleeves. 

• Attach subassemblies such as collars.

Using stationary cloth

In some scenes, you might want to use a cloth object that doesn’t 
change position or shape during playback. For example, you 
might want to include an unmoving tablecloth.

To create stationary cloth

1 Run the simulation and stop it when the cloth has the desired 
shape.

2 Save the current shape as the initial cloth shape. 

3 You can do either of the following:

• Delete the cache. Select the appropriate solver and set its 
Start Frame attribute higher than the scene’s time range. 
This prevents simulation during subsequent playback. If 
you don’t do this step, the cloth changes shape a bit as the 
simulation runs.

• Export the cloth object with History turned off, and 
import it into the desired scene.

4 To practice creating a stationary tablecloth on your own, use 
the scene UnlimitedLessonData/Cloth/scenes/
tableClothStart.mb.

You can open the scene named tableClothStart.mb from 
the Maya Documentation, Lessons, and Extras CD or from the 
drive where you copied the Getting Started with Maya 
Unlimited data files.

This scene has a table and a group of four curves you can use 
to make the tablecloth.
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5 The four curves are connected as a square above the table. 
Though garments such as shirts and pants need many panels 
seamed together, a simple garment such as a tablecloth needs 
only one panel. The scene includes a material named 
tableClothMtl that you can assign to the cloth for a more 
realistic display. 
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With the fur feature, you can create fur and short hair on all 
surface types in Maya. You can set fur attributes such as color, 
width, length, baldness, opacity, curl, and direction for entire 
surfaces or specific regions. 

To bring fur to life, you can keyframe effects like growing fur or 
changing color. For a more natural appearance, you can also add 
movement to fur with keyframes and dynamics, for example, 
wind and gravity.

This chapter has the following topics:

• ”Preparing for the lesson” on page 163

• “Lesson 1: Applying fur to a surface” on page 164

Preparing for the lesson
To ensure the lesson works as described, do these steps before 
beginning:

1 Create a new scene. 

2 Select the Rendering menu set. Unless otherwise noted, the 
directions in this chapter for making menu selections assume 
you’ve already selected the Rendering menu set.

3 If you don’t see a Fur menu next to the Paint Effects menu, 
perform these additional steps:

• Select Window > Settings/Preferences > Plug-in Manager.

• In the Plug-in Manager, locate the Fur plug-in (Fur.mll) 
and turn on the loaded checkbox. Wait for the check mark 
to appear in the checkbox, then close the Plug-in Manager. 
You can set the Fur plug-in to auto load so that it 
automatically loads each time the Maya application is 
launched. Notice that Maya added the Fur menu next to 
the Paint Effects menu.
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Lesson 1 Applying fur to a surface
In this lesson, you learn about essential Fur features by making a 
fuzzy ball:

In this lesson you learn how to:

• Attach a fur description to an object.

• Modify fur attributes.

• Render the scene to view the fur.

Lesson setup
You will begin the lesson by creating a light, a sphere, and a gold 
material for the sphere. Later in the lesson, you’ll apply fur to the 
sphere. 

1 Select Create > Lights > Directional Light.

2 In the Channel Box, enter -50 for the light’s Rotate X value, 
and 20 for its Rotate Y value.

3 Move the light away from the center of the grid so that it’s 
easy to select after you add a sphere.
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A directional light’s orientation, not position, affects the aim 
of the lighting. 

4 In your scene view, select Lighting > Use All Lights so that the 
scene is lit by the directional light rather than the default light.

The directional light will display the fur more clearly than the 
default light.

5 Create a polygonal sphere with a radius of 8. Name it Ball.

6 Select Shading > Smooth Shade All to display the Ball with 
smooth shading.

7 Right-click the Ball and select Materials > Assign New 
Material > Lambert from the marking menu. 

8 Click the Color box to display the Color Chooser, choose a 
gold color, then click the Accept button.

9 Close the Attribute Editor.
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Creating fur on a surface
The next steps show how to attach fur and edit the fur attributes.

To create fur on a surface

1 With Ball selected, select Fur > Attach Fur Description > New. 
This attaches a new default fur description to the selected 
surface. A fur description defines all the attributes for the fur, 
for example, fur color, width, length, baldness, opacity, curl, 
density, and so on. The spikes are known as the fur feedback—a 
rough approximation of how the fur will look when rendered.

2 In the scene view, click a spike to select the fur feedback node. 
(Select a spike at the perimeter of sphere so you don’t 
unintentionally select the sphere also.)

The fur feedback (spikes) becomes highlighted.

Modifying fur attributes
1 In the Inputs section of the Channel Box, select 

FurDescription1. Rename FurDescription1 as 
ballFurDescription. This gives the fur description a name 
that’s easier to remember than the default name.

Enter these attribute values:

• Length: 3
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• Inclination: 0.4

• Scraggle: 0.4

• Polar: 0.75

Length sets the fur’s length, in grid units.

Scraggle sets the crookedness of the fur. A value of 0 creates 
no crookedness, while 1 creates maximum crookedness.

Inclination sets how the fur slopes or leans. A value of 0 is 
fully erect (normal to the surface), while 1 is flat (tangent to 
the surface at the root).

Polar sets how much the fur is rotated about the surface 
normal. 0 creates -180 degree rotation, 0.5 creates no rotation, 
and 1 creates 180 degree rotation.

2 In the Shapes section of the Channel Box, ensure the Fur 
Accuracy is set to 1. 

Fur Accuracy sets how closely the fur’s display in the scene 
view resembles the fur when rendered. A value of 1 displays 
best accuracy, 0 least accuracy. With a value of 1, you can see 
the effect of scraggle and curl without having to render. High 
values slow Maya operation speed. 

3 Select Fur > Edit Fur Description > ballFurDescription to edit 
the fur description attributes.
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4 Set the Base Color and Tip Color by clicking each color box 
and selecting the color from the Color Chooser. For example, 
choose a yellow-gold for the Base Color and a orange-gold for 
the Tip Color.

5 Enter 0.75 for Tip Opacity and 0.01 for Tip Width.

Tip Opacity sets the transparency of the ends of the hair. A 
value of 0 is transparent, while 1 is completely opaque. Tip 
Width sets the width of each hair at the tip.

6 To have the fur’s color in the scene view approximate the fur 
when rendered do the following:

• Select one of the spikes to select the fur feedback node.

• In the Shapes section of the Channel Box, set Color 
Feedback Enabled to On.
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Rendering fur
To see the fur in full detail, you need to render the scene. 

To render the fur

1 Select Window > Rendering Editors > Render Globals and 
click on the Common tab.

2 In the Resolution section of the Render Global Settings 
window, select 640x480 from the Presets drop-down list.

When you test render the scene, the resulting image size (640 
by 480) will be large enough to see fine detail.

3 Select Render > Render Current Frame.

The fur looks too sparse. Fortunately, only a few easy steps 
are necessary to increase the fur density.

To modify the fur density

1 In the scene, select a spike that represents the fur.

2 In the Inputs section of the Channel Box, click 
ballFurDescription. 

3 Enter 30000 for Density.

This specifies the number of hairs on the surface. The higher 
the value, the thicker the fuzz.
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4 In the Render View window, select Render > Redo Previous 
Render.

5 Experiment with other attribute values and use 
Render > Redo Previous Render as necessary.

Beyond the lesson
Before exploring how to apply the lesson, it’s worthwhile to 
review the general steps of using fur:

• Create the desired lights.

• Attach a fur description to the surface.

• Modify fur attributes.

• Animate fur attributes (optional, not shown in this lesson).

• Add movement to fur (optional, not shown in this lesson).

• Set up fur shading effects (optional, not shown in this lesson).

• Render the scene.

• Refine attribute settings and render again.

In the lesson, you attached a new fur description to a single 
selected surface. You can also attach a fur description to multiple 
selected surfaces, for instance, a cat’s body, legs, and head.
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Though not covered in the lesson, it’s often useful to alter the fur 
attributes using the Paint Fur Attributes Tool. With this tool, you 
paint values for fur attributes on a specific region. For example, 
you can paint length values on part of a surface to make the 
painted patch of fur longer than the rest of the fur. With this tool, 
you can even paint the direction of the fur as if you were using a 
comb.

You can also attach more than one fur description to a surface. For 
example, you can add an additional fur description to a surface 
around a cat’s nose for its whiskers. Note that only the most 
recently applied fur description is displayed in the scene view.

Though not included in the lesson, you can keyframe changes you 
make to fur attributes to animate effects such as growing fur or 
changing fur color. You can add movement to fur with attractors 
and dynamics. Using attractors, you manually keyframe fur 
movement. Using dynamics, you make the fur react to forces, for 
example, wind and gravity. You can also use dynamics to cause 
fur to react to movement of the attached surface, for example, 
when a dog shakes itself.

Finally, you can create fur shadowing effects by adding and 
setting fur light attributes on the lights in your scene.

For further information and related techniques about Fur, refer to 
the Maya Help.
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Maya Live simplifies the process of matchmoving. Matchmoving is 
the process where you match the camera or object movement in a 
live-action shot with the camera in Maya. This subsequently 
allows you to place your 3D objects into live-action footage.

Matchmoving is an iterative process where the camera movement 
for the Maya camera is calculated using processes of tracking and 
solving.

Objects are tracked in the live action scene and a solver then 
calculates the camera position for a given image. This chapter 
includes the following lessons: 

• “Lesson 1: Track and solve” on page 179

• “Lesson 2: Solving with survey data” on page 203

About Live
Suppose you must replace a live-action fence with a fence 
modeled in Maya. In the live-action shot, the camera sweeps 
around the fence. You can use Live to animate a Maya camera that 
sweeps around your modeled fence in the same way. When you 
render the Maya fence from this camera, it will have the same 
camera perspective as the live-action fence. You can therefore 
composite them together precisely.

Live-action shot of fence
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Live can also match the movement of objects in the live-action 
shot. Suppose you want to replace the hat of a moving, live-action 
person with a cartoon hat created in Maya. You can use Live to 
create 3D locators that follow the movement of certain points on 
the live-action hat. You then attach a hat created in Maya to these 
moving points, so that the rendered Maya hat follows the 
movements of the live-action person. The steps for matching 
object movement are about the same as matching the camera. 

To use Live, you do the following major tasks in order: 

Setting up

You begin by loading digital images of the live-action shot. In this 
lesson, you’ll use images scanned from film footage. 

Images appear on an image plane. This plane is part of the Maya 
camera. It displays images as part of a background. 

Matching Maya camera view and modeled 
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Track

In this task, you mark a variety of points within the images, such 
as the center of a flower or a mark on the fence, and have Maya 
track how they change position from frame to frame.

Solve

In this task, you run a solver program that computes an animated 
camera, based on the movement of the track points.

Fine Tune

This is an optional task where you can make frame-by-frame 
adjustments to the camera position. (This task is rarely used and is 
not covered by this lesson.)
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Preparing for the lessons
In the following lessons, you will create a match move for live 
footage of a sweeping shot of a backyard and fence. In the second 
lesson, you will load a fence created in Maya to evaluate how well 
the Maya camera movement matches the live-action camera. 

To ensure the lesson works as described, do these steps before 
beginning:

1 Make sure you understand the basic usage of the animation 
playback controls. See the chapter entitled “Animation” in 
Getting Started with Maya to learn about these controls.

2 Select Window > Settings/Preferences > Preferences. Click the 
Timeline category under Settings and make sure the Playback 
Speed is set to Play every frame. Animation plays more 
accurately with this setting. 

3 Locate the Live lesson data on the Maya Documentation, 
Lessons, and Extras CD. It exists on the CD in this location:

UnlimitedLessonData/Live

You can work from the CD directly or copy the directory to 
the local work area of your choice. If you copy the directory, 
you need about 300 Mbytes of free disk space. 

4 If Live doesn’t appear in the menu set selection menu, select 
Window > Settings/Preferences > Plug-in Manager. In the 
Plug-in Manager, locate mayalive.so (IRIX) or mayaLive.mll 
(Windows) and click the loaded checkbox. Wait about 20 
seconds for the operation to finish, then close the Plug-in 
Manager.

5 Select the Live menu set. All instructions in this lesson assume 
you have the Live menu set selected.

6 Choose Scene > New Matchmove. 
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When you create a new matchmove scene, Live places the 
Setup control panel at the bottom of the standard Maya 
window. There are different control panels for each of the 
main tasks: Setup, Track, Solve, and Fine Tune. The control 
panel is where you control most of the Live operations. 

Also notice Live creates a camera and an image plane in your 
scene. This is the camera Live animates. The image plane 
serves as the background plate when you look through the 
camera. It is where the images for the live shot will appear 
once you’ve loaded them. 

Setup control panel
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Lesson setup
You begin the lesson by loading digital images of a live-action 
sequence. You’ll work with images we created for your use.

To load and set up the images for the lesson

1 In the Setup control panel, click the Browse button next to the 
Full Res Image box. 

2 Navigate to the UnlimitedLessonData/Live directory and 
select any image file from the list, such as shot1BG.rgb.0001.

3 Click the Open button. Live loads the entire image sequence, 
from shot1BG.rgb.0001 to shot1BG.rgb.0240.

4 From the Predefined Filmbacks list (on the Setup control 
panel), choose 35mm Full Aperture. 

Filmback is the aspect ratio (width/height) of the exposed 
film negative used during filming. Before using Live, you 
need to find out which filmback was used during filming. 
Without it, Live cannot determine the correct angle of view 
(camera aperture) and focal length.

Note If the images do not appear on the image plane, you 
may need to adjust the image cache settings. Click the 
Cache option on the far left to display the cache settings. 
Set Texture Method to Image. If the images still do not 
appear, try selecting None. 
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Lesson 1 Track and solve
This lesson guides you through the main tasks in Live: tracking 
and solving. In this lesson you learn how to:

• Review footage to determine the location of tracking points.

• Position tracking points for the live-action footage.

• Track points in the scene

• Evaluate how closely points are tracked using the Track 
Summary panel.

• Modify the location of tracking points for a scene.

• Import track points into Maya.

• Solve for the camera movement.

• Evaluate and modify the solution that the Solver creates. 

Tracking provides Live with information about the way objects in 
the shot appear to move. Just as objects move in your field of view 
when you walk by them, the way objects move in the camera view 
gives Live information on how the camera moved during filming. 

You’ll track points for various spots, such as a mark on the fence. 
To track a point, you mark each spot in the image and have Live 
run a tracker that automatically follows the point’s movement 
from frame to frame. The result is called a track point. 

Later, in the solve task, Live will animate a Maya camera based on 
the track point movement. 

Tracking preparation
Which spots should you track? To answer this question, do these 
steps:
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To review a shot and plan for the tracking

1 Open the Track control panel by clicking the menu on the far 
left of the control panel and choosing Track. 

Above the Track control panel, Live displays preset view 
panels. The view panels match the needs of tracking. The 
following illustration labels these panels, shown the way they 
might look at the end of the lesson. 

2 Play the shot and watch it in the shotCamera view panel. 
Don’t worry if the playback seems jerky, because you are only 
getting a rough look at how the camera moves. In fact, you 
can skip through the frames quickly by dragging in the Time 
Slider. 

Pull-down 
menu

Track control 
panel

Track 
Summary

pointCentered 
view

shotCamera 
view
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The following figure gives recommendations on which points 
to track (you will have a total of 15 in the end). You will track 
two of the points and import the other points from a prepared 
file. 

Note Playing shots can be slow because the images require a 
lot of memory. To speed up playback, Live has settings 
for creating an image cache (Setup Cache control panel). 
Image cache is an allocation of system memory 
dedicated to storage and retrieval of images so that they 
play back faster. For this lesson, the default image cache 
settings usually suffice. If you later find that caching the 
images appears too slow you can change the Pixel Type 
from the default RGB setting to Luminance. This will 
cache black and white versions of the images thereby 
reducing the amount of data cached and increasing the 
performance of tracking points in Live.

Points far from the camera

Points close to the camera and spread across the film set

Points visible for a 
long duration and in 
the area where the 
replacement fence 
will be
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Tracking object points in a shot
In the next steps, you track the motion of a flower. Tracking 
points on the ground is common practice and the flowers are easy 
targets to track.

To track objects in the shot

1 Go to frame 1. 

2 Click the Create button in the Track control panel. Live places 
a track box in the center of the shotCamera view, ready for 
you to reposition. 

If you don’t see a full-color image of the scene in the view, go 
one frame forward in the Time Slider and go back to the start 
time to refresh the view.

3 Before you reposition the track box, enter flower1 in the Name 
box in the Track control panel. We recommend you name 
track points for future reference. 

4 In the Track control panel, click the track box tool so you can 
reposition the track box. 

If you switch to another tool, such as rotate, remember to 
select the track box tool again if you thereafter need to move 
track boxes. 

5 In the shotCamera1 view, drag the track box down to the 
fourth clump of flowers from the right. 

Track box tool
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This pair of flowers is good to track because it is visible in all 
frames. Strive to track points that are visible for a large 
number of frames. 

6 In the pointCenteredCamera view, drag the image until the 
track box cross-hair is centered over the flower closest to the 
fence. Dragging in this panel has the opposite effect from the 
shotCamera view, because you are actually panning the 
camera, not moving the track box. 

Notice that the track box resizes if you drag the edges. For this 
track point, keep the boxes at the default size. Choose Edit > 
Undo if you resize it accidentally. It may require a number of 
Undo commands to return to the original configuration of the 
track box.

Fourth clump 
of flowers 
from the right

Fence 

Flower
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The point you are tracking is at the center of the track box 
cross-hair. To track this point, Live uses the pattern of pixels 
defined by the inner box. The outer box is the range Live 
searches for the target pattern.

7 Make sure Tracking Direction is set to Forward. 

During the course of creating track points, you will change 
this setting often. Depending on the situation, you might track 
Forward, Backward, or Bidirectional. 

8 Click the Start Track button.

First a progress dialog box appears, then a movie of the track 
point. These point-centered movies are important tools for 
evaluating how closely the track point stays on target (see the 
following steps).

Cross-hair 
defines the 
target point

Inner box 
defines the pixel 
pattern Live 

Outer box 
defines the range 
Live searches for 
the target pattern
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Evaluating the tracking of a point
Making sure the track point stays on target will help later when 
you solve. Don’t worry if the connection between tracking and 
solving is not clear yet. For now, simply identify major tracking 
errors by following these steps:

To evaluate the flower1 track

1 Review the movie file that Live generates at the end of 
tracking. 

Identify any areas where the cross-hair slips noticeably from 
the original position on the flower. This takes some judgment. 
Since the flower changes shape over time, you must visualize 
where the original point would be as the camera perspective 
changes.

If the cross-hair appears to stay within two pixels of the 
original target point, you have tracked the flower successfully. 
If the cross-hair moves completely off the flower or the 

Progress window Movieplayer
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tracking stops before it reaches the last frame, you must track 
again. Delete the track point (click Delete in the Track control 
panel), return to frame 1, position the track box cross hair 
exactly in the center of the flower closest to the fence, and 
click Start Track. 

2 Close the Movieplayer window.

3 Look at the graph in the Track Summary panel. 

This graph shows how closely Live matched the track box’s 
pixel pattern on each frame. Specifically, Live compares each 
frame and the frame before it to see how well they match. 
Green is a good match, yellow is a warning, and red is a 
stronger warning. 

As illustrated, the green region drops over time, leaving the 
graph mostly yellow toward the end. This is a normal 
occurrence, caused by the changing pixel pattern of the point 
you tracked. In this case, you can ignore the yellow color, 
because the main evaluation tool—the movie file—indicates 
the track is on target. 

Note The curvy blue (or red) line next to the track point is a 
trace line. It is an optional tracking feature you will not 
use in this lesson. 
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Tracking additional points 
Now that you’ve tracked one point successfully, you’ll continue 
with tracking a different spot in the image sequence. In general, 
you keep tracking points until you have enough to solve. (You 
will learn how to make this determination later in the lesson.)

The point you are about to track demonstrates what to do if the 
spot falls out of view midway in the shot.

To track the fence corner 

1 Go to frame 1.

2 Click Create and drag the track box over the bottom corner of 
the far right fence post. If you have trouble dragging the track 
box, click the track box tool again: 

3 In the PointCenteredCamera view, position the track box to 
match the following illustration. 

Fence 
corner
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Knowing where to position the track box involves two 
important factors. One factor is the pattern framed by the 
inner target box. This pattern must have at least some contrast 
and must be distinct from the surrounding region that is 
framed by the outer box. By having a distinct pattern within 
the inner target, you will prevent the tracker from jumping off 
target and onto a similar pattern. 

Another important factor is choosing where you place the 
cross-hair. You want it to be over a spot that you can 
recognize in later frames when the pattern changes. By 
aligning the vertical cross-hair line with the post edge and the 
horizontal cross-hair line with the bottom of the post, you can 
identify this same spot in later frames. 

4 Type fenceCorner in the Name setting. 

5 Click Start Track. 

The tracker stops around frame 60 or 80 because the corner 
falls out of view. The track box also moves off target toward 
the end. You will correct both of these tracking problems in 
the next steps. 

Deleting tracking data
Because the fence corner disappears from view in the middle of 
the shot, you need to skip several frames and track from where it 
reappears. First, you need to remove the bad tracking data where 
the track box moves off target.
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To delete the bad tracking at the end, you use the Track Summary 
panel (the panel below the pointCenteredCamera view). 

To delete the bad tracking data

1 To see fenceCorner’s tracking graph better, click the Track 
Summary panel and tap the space bar. 

2 You need to select and remove the tracking data after frame 
52—the last frame still on track. To identify this frame in the 
graph, move to frame 52 in the Time Slider. In the Track 
Summary panel, a black bar shows the location of frame 52. 

3 In the Track Summary panel, draw a selection box from right 
to left around the end of fenceCorner’s graph. Do not select 
beyond the black bar that indicates frame 52. Also, be careful 
to select only the frames for fenceCorner, not flower1.

4 In the Track Summary panel, choose Edit > Delete Region. 
Live removes the bad tracking data from fenceCorner. 

Deleting regions where the track is off target is crucial to 
successfully solving your shots. Whenever you find difficulty 
tracking a point for a specific segment of frames, consider 
deleting the tracking data. 

5 Tap the space bar to shrink the Track Summary panel.

To continue tracking data in the shot

1 Move to frame 143, where the fence corner reappears in view. 
In the following steps, you will continue to track from this 
frame to the end of the shot. 
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You’ll skip tracking a large amount of frames for the 
fenceCorner point (the ones in the middle of the graph), 
which is common practice when creating track points. In 
general, track as many frames as possible for each point and 
skip, retrack, or delete any frames where the tracker does not 
stay on target. 

2 Reposition the track box over the fence corner. In the 
pointCenteredCamera view, align the vertical cross-hair line 
with the edge of the fence post and the horizontal cross-hair 
line with the bottom of the post. 

3 Shorten the track box’s inner target box by clicking the inner 
target box’s bottom edge and dragging up as shown below. 
The tracker will not work if the target area extends beyond the 
image.
Getting Started with Maya Unlimited

190



6 | Live
Lesson 1 > Importing tracking data
4 In the Track control panel, click Start Track. If the tracker 
successfully tracks to the last frame, you’ll see a graph similar 
to the following illustration. (The second track area will be 
mostly green or all green in the Track Summary.)

If the tracker fails to create a graph similar to the above 
illustration, three actions might have occurred:

• The tracker stays stuck at the same frame and the animation 
frame doesn’t advance

• The tracker stops before the final frame

• The tracker drifts off target

Whichever of these actions occurred, repeat the previous step, 
but this time shorten the track box’s inner target box.

Importing tracking data
To reduce the repetition of tracking many more points in this 
lesson, you import additional track points for the scene from a file 
we created for your use in this lesson.

To import track data 

1 Choose Track > Import Track Points from the Live menu set.

2 Navigate to the UnlimitedLessonData/Live/points 
directory and open fence_1.txt.

This imports the track point data for seven more points. (The 
track data was created using the Track > Export Track Points 
operation.) Ordinarily, you will not need to use the export 
and import operations; they are intended for situations where 
you start over with a new scene but want to retain track 
information. 
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Preparing to solve
Are there enough track points for you to solve the camera 
movement? Follow these instructions to see how you make this 
decision.

To decide if you are ready to solve for the camera 
movement

1 In the Track Summary panel, choose View > Frame All.

2 For each frame, make sure there are at least four points with 
graphed tracked data. Experience has shown that four points 
is the minimum average you need to solve a shot. 

In the middle frames, such as frame 135, there is less track 
data. However, on this frame and all frames in the middle, 
there are at least four. 

3 Look for large areas of red in each track point’s graph. 

Small areas of red are okay. A track point’s graph does not 
have to be completely green in order to solve. In general, if 
you do find a large area of red for a point, either retrack over 
the region or select it in the Track Summary graph and choose 
Edit > Delete Region. 
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4 As a preventive measure, look for blue tick marks in the 
graphs for flower1 and fenceCorner—the track points you 
created. 

A blue tick mark indicates you moved the track box for that 
frame. You may have moved it accidentally—for example, if 
you clicked on the track box to select it. Click on the blue tick 
mark to go to that frame. Then, in the pointCenteredCamera 
view, compare the frames next to this frame. A shift as small 
as one pixel can cause problems when you solve. 

If you see a sudden shift between the frames, go to that region 
in the Track Summary graph, select two or three frames (you 
can simply estimate), and choose Edit > Delete Region.

5 Look at the Ready to Solve bar at the bottom of the Track 
Summary. 

It’s mostly green and yellow, with little red. The red area is 
mostly in the middle because there is less track data there. 
However, since you meet the minimum number of points, it’s 
worth trying to solve. You can always add more track points 
later.

Solving the shot
The solver is the part of Live that animates a Maya camera. You 
rarely obtain a correct solution the first time you run the solver. 
Once the solver is run, you need to evaluate the solution and 
make improvements to the track data until the solver can create a 
correct solution.

To solve the shot

1 Open the Solve control panel by clicking the control panel 
menu on the far left and choosing Solve. 

The Solve control panel has a different arrangement of view 
panels than the ones you used for tracking. You will learn 
about these other panels as you continue with the lesson.
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2 In the Solve control panel, click the Solve button to begin the 
solve process. This process will take several minutes to 
complete. (You do not need to go to frame 1 when you solve; 
Live solves for all frames by default.)

Notice the column of buttons next to the Solve button, with 
Start at the top and Register at the bottom. These buttons run 
the solver in stages—the same stages that it performs when 
you click Solve. Running the solver in stages is only for 
advanced use; you can ignore these buttons for now.

When the solver finishes, the solution, called solution_rf, 
appears in the solution list on the Solve control panel. Because 
you will run the solver several times, Live keeps a list of each 
solve attempt.

A solution consists of an animated camera and locators, which 
appear as crossed lines in the perspective view. Locators are 
marks in the world space that you can use as reference points 

Solve control 
panel

shotCamera 
view

Perspective 
view

Locator 
Summary Graph Editor
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when modeling. Each locator corresponds to a track point and 
has the same name, plus the suffix “_3D,” such as 
fenceCorner_3D. 

The following illustration shows an example solution with 
these parts labeled. Note that images do not appear on the 
image plane in the perspective view because this view is in 
wireframe mode. 

Evaluating a solved solution 
Now you must determine if the solution correctly matches the 
camera movement. If correct, the solution locators will be 
arranged like the points from the actual film set. For example, the 
points along the fence should be aligned along a plane. Also, 
Maya’s camera will move around the locators in a way similar to 
the real camera movement.

To evaluate the solved solution

1 Check the Overall Pixel Slip in the Solve control panel. 

The Overall Pixel Slip is a general indicator of the solution’s 
accuracy. Overall means it is an average for all points on all 
frames. Pixel slip measures how well each 3D locator matches 
with the track point in the background—as viewed through 

LocatorsSolved camera Image plane 
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the solved camera. For example, if flower1 and flower1_3D 
appear separated by one pixel on all frames, the pixel slip is 
1.0. The lower the pixel slip, the more accurate the solution. 

Ideally, Overall Pixel Slip should be less than 2. But this 
doesn’t mean the solution will mimic the live footage camera 
movement satisfactorily. In the next steps, you’ll find out 
whether it does. 

If Overall Pixel Slip reads “poor” or a number higher than 2, 
you need to fix a problem in your track points. Return to the 
Track control panel and repeat the instructions ”Preparing to 
solve” on page 192. 

If you still cannot reach a solution below 2, we recommend 
you continue the lesson using a scene we have prepared for 
you. Choose File > Open Scene, navigate to the 
UnlimitedLessonData/Live/scenes directory, and double-
click goodPoints.mb. Live loads a scene with the same track 
points, carefully created to avoid problems. When you click 
Solve in the goodPoints scene, your Overall Pixel Slip will 
read about 1.0.

2 Play the animation and tumble the perspective view while the 
animation plays so you can see how the camera moves. 

You need to judge whether the camera moves the way you 
expect. You know the camera starts above the set and moves 
down, so it should start above the locators and sweep down 
in the same way. Compare the frames in the following 
illustration.
Getting Started with Maya Unlimited

196



6 | Live
Lesson 1 > Evaluating a solved solution
In this case, the camera starts below the locators and moves 
up instead of down. It also makes a series of abrupt 
movements. This solution is incorrect. 

3 Stop playing the animation. 

4 For further evaluation, examine the graphs in the panel on the 
lower left. This is the Locator Summary.

The Locator Summary graphs the pixel slip of each point over 
time. You already looked at the overall pixel slip, but the 
Locator Summary lets you find which point has the most pixel 
slip and on which frames. 

Frame 100Frame 1
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If one point had a very red and yellow graph, you could 
conclude that the point was the source of the problem 
solution. In this case, many points have red and yellow areas, 
but those areas appear mainly in the first 100 frames. 

Because red and yellow areas all occur within the first 100 
frames, you can conclude that the solver does not have 
enough information for those frames. To improve the 
information, you’ll need to add one or more track points for 
those frames. 

How many points you’ll need is not important to fixing this 
problem. Rather, choosing the right points is what will help 
the solver. In the following steps, you’ll load another set of 
points into your scene. These points will illustrate which types 
of points to choose. 

Importing additional tracking data
To help you improve the solution, we have created another set of 
track points for you to import.

To import the additional tracking data

1 Choose Track > Import Track Points.

2 Navigate to the UnlimitedLessonData/Live/points 
directory and double-click fence_2.txt. Live loads five more 
track points. 

Note The other panels in the layout are the Graph Editor and 
the shotCamera. The Graph Editor is for advanced 
users. It can be helpful for examining the camera 
animation curves so that you can pinpoint problem 
areas. The shotCamera panel is useful in later stages, 
after you have a correct solution. You can ignore both of 
these panels for now. 
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3 Click Solve. 

While the solver runs, examine the following illustration to 
learn about the points you just loaded and why they were 
chosen to improve the solution. 

In general, having a diversity of points, such as points far and 
near the camera, is critical to helping the solver. 

4 When the solver finishes, solution_rf1 appears in the solution 
list. Check the Overall Pixel Slip in the Solve control panel. It 
reads about 0.322, so the new points have made an 
improvement. 

If you have a larger Overall Pixel Slip, the problem may be 
that initial1 was selected when you solved again. Try selecting 
solution_rf instead and clicking Solve again. The solution you 
have selected when you click Solve can affect the outcome of 
the solver.

5 Play the animation and watch in the perspective view. 

In this case, viewing from below the grid is best because the 
locators and camera are below the grid in this solution. You 
must ignore where Live has placed the camera and locators 
relative to the perspective grid. 

Points far from 
the camera

Points spread 
across the film 
set
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Only look at the arrangement of the locators and the 
movement of the camera. They should resemble the 
arrangement of points and the camera motion as seen in the 
shot. For example, notice the points along the fence are 
aligned along a plane, just as they are in the shot. 

If you compare frames 80 and 180, you’ll see that the camera 
now moves downward relative to the locators. This 
movement is what you would expect the camera to do for this 
shot.

At this point, you can assume that your matchmove is 
complete and accurate. However, to be absolutely sure, you 
need to play the animation with a model placed in front of the 
camera. If the model does not appear to slip relative to the 
background, then your matchmove is accurate. To learn about 
this type of testing, continue with the next lesson. 

6 If you plan to continue with the next lesson, we recommend 
you first save your scene into the current scenes directory. 

Live Lesson 1: Beyond the lesson
In this lesson you learned the fundamentals of the Live workflow.

You learned how to:

• Position tracking points for the live-action footage.

• Track points in the scene

Frame 180Frame 80
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• Evaluate how closely points are tracked using the Track 
Summary panel.

• Modify the location of tracking points for a scene.

• Import track points into Maya.

We made numerous decisions for you regarding which points 
to track and how to improve the solution. With more practise, 
you will learn these decision-making skills. Additionally, you 
may want to review the section on “Shot Strategy” in the 
Maya Help.

• Solve for the camera movement.

• Evaluate and modify the solution that the Solver creates.

In general, you can expect to run the solver several times to 
find a correct solution. Before each solve, make improvements 
by adding track points in a variety of places and by deleting 
regions from the track data if they are not accurate. Even if 
one track point is off alignment on one frame, it could result 
in an incorrect solution. 

Your solution has the correct camera movement, but you may 
wonder why the camera and locators are placed below the 
perspective view grid. If you want to control where the 
solution is placed within the scene, you need to give the 
solver more information, called survey constraints. Continue 
with the next lesson to learn more. 

Exporting and rendering solutions

With the camera movement solved, you can create your animation 
using the solved camera to make sure the animation does not 
move out of the camera view. If your animators use Maya 
Complete or another software product, you must export the 
camera solution from Live (Scene > Export Scene As). You can 
also export to other 3rd party 3D and compositing applications.
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When you render the animation, we recommend you do so 
without the image plane background. A better workflow is to 
render the animation created in Maya separately and then use a 
compositing software application to combine it with the live 
footage background. 

However, if you do want to render the image plane, you must 
turn off the Use Cache option on the Setup control panel. The Use 
Cache option utilizes a Roto node, which does not render. By 
turning Use Cache off, Live switches to the standard Maya image 
plane, which is renderable.
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Lesson 2 Solving with survey data
This optional lesson is a continuation of the previous lesson.

The objective in this shot is to replace the filmed fence with a 
fence modeled in Maya. Suppose you had taken measurements of 
the fence from the film set and used the measurements to model a 
fence in Maya. The locators created by Live would not match the 
same scale that you used for the model. Also, the locators and 
camera Live created are not near the perspective view grid, which 
is a convenient reference for modeling and animating.

To solve these issues, you can incorporate the measurements you 
surveyed from the set into the Live solver. You do this with the 
survey constraints feature.

In this lesson, you learn how to change the positioning of the 
camera and locators within the Maya scene. You typically need to 
do this so you can more easily model and animate objects you 
want to match up with the live shot. You will learn how to:

• Create a variety of survey constraints.

• Apply survey constraints to the solution.

• Evaluate the solution with imported geometry.

Even if you do not have survey measurements, you can use 
estimates to change the spacing between locators and their 
orientation within the Maya scene. 

Creating a Distance constraint
Live has a variety of survey constraints. As your first example, 
you will create a Distance survey constraint. The Distance 
constraint defines the distance between two tracked points. Based 
on that one distance, the solver can establish the distances 
between all the locators. 
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To create a Distance constraint

1 Open the Live scene you created in the previous lesson. 

2 In the Solve control panel, click the Survey option to open the 
survey constraint settings. 

3 Choose Distance from the Constraint Type menu. 

Now you’ll need to specify two points that you want to 
constrain to a distance. 

4 To help select the points, open the Outliner (Window > 
Outliner). 

5 Select the following track points in the Outliner under 
clip1TrackedPointVisibilityGroup > clip1TrackedPointGroup:

• fenceCorner

• tileInFront

6 In the Solve Survey control panel, click Create.

7 Enter 2 in the Distance setting.

With this constraint, Live will force the locators for 
fenceCorner and tileInFront to be 2 units apart. Live does not 
incorporate the constraint until you run the solver again and 
create a new solution. You will do this later in the lesson.

This constraint is not based on a film set measurement; it is 
simply an estimate. Using estimates to control the space 
between locators is often useful, but be careful not to use too 
many estimates. Too many estimates can prevent the solver 
from finding a solution. 

Creating a Plane constraint
In addition to the space between locators, you may want them to 
be repositioned within the scene. For example, you may want the 
flower locators in the solution to rest on top of the perspective 
view grid, just as the flowers in the shot rest on the ground. In the 
current solution, the flower locators rest below the grid. 
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A convenient way to bring points onto the grid is to use a Plane 
constraint, which aligns locators onto a plane.

To create a Plane constraint for the ground

1 Choose Plane from the Constraint Type menu.

2 Select the following track points in the Outliner under 
clip1TrackedPointVisibilityGroup > clip1TrackedPointGroup:

• flower1

• fenceCorner

• flower2

• tileInFront

In the shot, these points correspond to points on the ground. 

3 Click Create. Live places the Plane constraint on the 
perspective view grid by default. 

4 In the Solve Survey control panel, change the Name setting to 
ground. Because you will later create another Plane constraint, 
you should give this constraint a unique name. 
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Registering a solution
To incorporate your survey constraints, you could solve from 
scratch (click Solve). However, you do not need to. You already 
have an accurate solution; you only want to incorporate the 
survey constraints. 

For this reason, Live lets you run the last step of solving: Register. 
In this step, the solver applies survey constraints to the solution as 
a whole without changing the relative positions of locators and 
the camera.

To register the solution

1 Click the Solve option to switch back to the Solve settings.

2 Make sure solution_rf1 is selected from the solution list.

This is the most accurate solution so far, so you want Live to 
apply the survey constraints to this solution.

3 Click the Register button. 

When the solver finishes, registered appears in the solution list. 
In the perspective view, you can see the flower, fence corner, 
and tile locators aligned with the grid. 
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If you dolly in the view, you’ll also see that the locators for the 
points you constrained by distance—fenceCorner and 
tileInFront—are now about two grid units apart. 

Creating additional Plane constraints
A top view reveals an illogical placement of the fence locators. 
Instead of being aligned with the XY plane, they are at an angle. 
To correct this problem, you need another Plane constraint that 
represents the fence.
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To create a Plane constraint using the fence locators

1 Click the Survey option to switch to the Survey settings.

2 Make sure the Constraint Type is still set to Plane. 

3 Select the following track points in the Outliner under 
clip1TrackedPointVisibilityGroup > clip1TrackedPointGroup:

• fenceCorner

• fenceX4

• fenceX1

• fenceRailSpot

• fencePostEdge

• fenceleft1

• fenceleft2

These are the points that are on the front of the fence.

4 Click Create.

5 Change the Name setting to fence. 

6 In the Channel Box, rotate the fence plane by entering 90 in 
the Rotate X attribute. Because the real fence is at a 90 degree 
angle to the backyard ground, you must rotate the fence 
constraint the same way in Maya.
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In this case, only the plane’s rotation matters, not where you 
move it. No matter where you move the fence Plane 
constraint, the fence points will remain on the grid because 
the solver must obey the ground constraint you created. 

The scale of the Plane constraint never matters because the 
solver treats it as infinitely large. 

7 Switch to the Solve control panel, select registered from the 
solution list, and click the Register button. The solver creates 
registered1 with the fence points aligned with the XY plane. 

Evaluating the solution with imported 
geometry
The best evaluation of your solution is to set an object in front of 
the solved camera and see if it matches the background as you 
play the animation. In this case, we will import a fence modeled in 
Maya.
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Before you load the modeled fence, do the following steps to add 
one more survey constraint. You add a Point constraint to orient 
the solution so fenceCorner is at the origin. You need fenceCorner 
at the origin because the fence model has its corner at the origin 
and you want the two to match exactly. 

To reorient the solution with fenceCorner at the origin

1 Switch to the Survey settings.

2 Choose Points from the Constraint Type menu.

3 Select the following track point in the Outliner under 
clip1TrackedPointVisibilityGroup > clip1TrackedPointGroup:

• fenceCorner

4 Click Create. Maya creates a Point constraint in your scene, 
located at the origin (0,0,0) by default.

5 Switch to the Solve control panel, select registered1 from the 
solution list, and click the Register button. The solver creates 
registered2 with fenceCorner at the origin.

You will now import a fence that has been modeled to exactly 
match the fence that was filmed. 

To import a modeled fence 

1 Choose File > Import.

2 Navigate to the UnlimitedLessonData/Live/scenes 
directory in the Import browse window.

3 Double-click fenceModel.mb to import it. 

To evaluate the solution

1 Hide the Plane constraints by selecting them and choosing 
Display > Hide > Hide Selection. By hiding them, you can see 
the fence better. 
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2 Enlarge the shotCamera view panel, which is in the upper 
right of the Solve panel layout. This panel shows the view 
from the solved Maya camera. 

In frame 1, you can see that the modeled fence accurately 
matches the fence that was filmed. To quickly see if it matches 
well in the other frames, you can scrub through the shot in the 
Time Slider. 

3 To scrub through the shot, drag slowly from left to right in the 
Time Slider. 

The fence model does not appear to slip in relation to the 
background, so this confirms that the solution is accurate. If 
you rendered a sequence of the camera moving around the 
modeled fence, you could composite the sequence with the 
original background and they would exactly match.

Although scrubbing tends to skip frames, it gives a 
preliminary confirmation that the fence model matches the 
background in all frames. 
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4 To evaluate the solution in a more accurate playback, select 
Window > Playblast.

The Playblast movie is an approximation of how the rendered 
sequence will appear. In this movie, you can look for subtle 
mismatches between the model and the background, such as 
momentary jitter. 

Beyond the lesson 
In this lesson you learned how to apply survey constraints to 
improve the overall solution.

Survey constraints are useful not only for orienting your solution, 
but also for the initial creation of a solution. In these lessons, you 
solved using track data alone, but this shot is fairly simple. In 
more complex shots, the solver may fail unless you use survey 
constraints to broaden the information that the solver can use. 

You cannot tell in advance which survey constraints are needed to 
solve a shot so it is a good idea to plan for some of the survey 
constraints before you start tracking. A common example is the 
Plane constraint, because most shots have coplanar or 
approximately coplanar points in them. 

Be careful not to add too many estimated survey constraints, 
because they may conflict with each other. When you create a 
Plane constraint for points that are only approximately coplanar, 

Note As an alternative to the Playblast, you could play the 
animation in Maya, provided you allocate enough 
memory in the Setup Cache control panel. If you have 
memory allocated for all 240 frames, the playback will 
be as fast and accurate as the Playblast movie.

If you do use the Playblast, you’ll need approximately 
20 Mbytes of free space in your computer’s temporary 
directory. 
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we recommend you turn on Registration Only in the Solve Survey 
control panel. This option keeps the solver from forcing the points 
to be perfectly coplanar.

Maya Live includes other constraints such as camera constraints 
and infinite points to help with solving. Camera constraints help 
control the focal length, translation, and rotation of the solved 
camera. You set them in the Solve control panel Camera settings. 

Infinite points are tracked points that you designate as infinitely 
far from the camera, such as a cloud, mountain, or any feature in 
the distant background. Knowing a point is infinite, the solver can 
use it exclusively for calculating camera movement. Infinite points 
are especially helpful for zoom shots, when the camera doesn’t 
move.

For further information and related techniques on Maya Live, 
refer to the Maya Help.
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eliminating 159

Iterations
hair 33

L
Length 167

hair 25

Length Flex
hair 33

Live 173–213

control panels 177

solver 194

starting 176

loading
Cloth 117

Fur 163

Live 176

Locator Summary 197

Locators
hair 36, 39

Lock Length
hair 30, 56
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M
Make Boats 109

Make Collide 74

hair 54

Make Motor Boats 110

manipulators, subvolume 91

match moving 173

Maya Unlimited
about 9

installing 12

restoring user 
preferences 15

saving user 
preferences 14

mayaLive.mll 176

mayalive.so 176

mcc file 159

Mesh
creating a constraint 154

mesh constraints 153

Modify Curves
hair 30

N
New Matchmove 176

Noise
hair 55

non-dynamic fluid 65

creating 77

description 65

non-hair simulation 48

Num Frequencies 105

Numeric Display 69

NURBS curves
hair 18

O
ocean

attributes, modifying 104

creating 101

plane 102

shader 101, 102

Opacity 83

Opacity Input 80

Outliner 119

Output
hair 18

Overall Pixel Slip 195

Oversample 40

Oversample Post Filter 40

P
Paint Effects hair 18, 39

Paint Fluids Tool 91

Paint Hair Tool 18

painting
Density 90

fluid properties 90

Fuel 90

Temperature 96

panels
changing shape after 
simulation 131

creating in cloth 119

planning 132

seaming 123

pants, creating 134

pantsMtl 143

Passive Fill
hair 25

Perlin Noise 81

Pitch 109

Plane constraint 205

Playblast for 
matchmoving 212

Plug-in Manager 176

Point constraint 210

Point Method 58

Points Per Hair 25

Polar 167

Ponds 111

creating 111

pose
character in cloth 114

positioning cloth 148

Predefined Filmbacks 178

preview plane 102

properties
cloth 126
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R
Randomization

hair 25

Register step 206

Relax Frame Length 157

render image plane 202

resolution 130, 131

Resolution Factor 140

resolution, fluid 78

Rest Position 25

Roll 109

S
Save as Initial Cloth State 149

Scraggle 167

scrubbing the Time Slider 130

seams
creating in garments 123

displaying 125

Selected Position 84

Self Shadow 86

self-shadowing, fluid 86

Set Rest Position 33

Set Start Position 28, 34

Set to Dynamic 73, 92, 96

Setup Cache control 
panel 181, 212

shader, fluid 80

Shading
hair 44

shirt, creating with cloth 118

shirtMtl 132

shotCamera view panel 180

Show Cloth 122

simulation
cloth 128

increasing speed 143

Size Rand 83

size, container 78

slice 90

Slices Per Voxel 95

Smooth
hair 32

Solve control panel 193

solver
cloth 128

deleting 153

exporting 145

selecting current 151

transferring garment 
to 152

solver for Live 194

Solver Scale 128

Specular
hair 44

Specular Power
hair 44

Specularity 107

Spottyness 83

Stamp Depth (3D) 96

Start Position 25

setting 28

Start Simulation 129, 131

Start Track button 184

Static Grid 96

Stiffness
hair 28, 33

Stiffness Scale
hair 33

stitcher node 123

Sub Segments
hair 41

subvolume manipulators 91

surface render 76

survey constraints 203, 212

Survey option 204

T
tableClothStart.mb 161

Temperature
fluid property 66

painting 96

Texture Opacity 81

Texture Scale 82

Texture Time 88

Texture Type 81

texturing, fluid 81

Thickness 155, 159

Thickness Force 155, 159

Thinning
hair 41

Tip Color 168

Tip Opacity 168

Tip Width 168

track box tool 182

Track control panel 180

track point 179

Track Summary panel 186

Tracking Direction 184

Transfer Garment 153
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turbulence 70

Twist
hair 31

U
U Bend Resistance 126

U Count
hair 25

U Scale 142

Update Cloth State 155

Use Cache option 202

Use Namespaces 147

user preferences
restoring 15

saving 14

V
V Bend Resistance 126

V Count
hair 25

Velocity, fluid property 66

volume pixels 69

voxels 69, 78

W
Wakes

creation 110

Warning
Cycle... messages 149

water, open 101

Wave Length Max 105

Wave Peaking 106

X
X, Y, Z Resolution 78

X, Y, Z Size 78
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